AVS Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
571 Posts
Discussion Starter · #1 ·
Thought I'd try a different angle in this forum as I have another going in the Builders forum HTPC & Lamplinc ..


Purchased an Avance CI-6004 w/proprietary 300W PSU from Digital Connection a couple of years ago (my current HTPC is still using it). Recently, I purchased a Lamplinc dimmer module from SmartHome (x10 like module) for some ropelight I installed in my HT room. Long story short, I've isolated the power supply as the only thing interferring with my Lamplinc as my ropelight will only dim/turn off when I toggle the switch in the back of the PSU off (also purchased a a 10amp FilterLinc which had no affect). Does anyone have a success story using this case/PSU with x10 like equipment? Does anyone know of a replacement 300W PSU that will fit in this case?


Thanks,

jidelite
 

·
Registered
Joined
·
247 Posts
Have you tried emailing digital connection and asking if you can just purchase a PSU? Their website doesn't give any information at all on the proprietary PSU and googling for the model number brings up a handful fo sites in languages I don't speak.


(a side note, I hate proprietary things, hardware, software, anything, and this si exactly why)
 

·
Registered
Joined
·
4,321 Posts
Both 300 and 350w are listed at our site and we will continue to carry replacement parts for these cases.
 

·
Registered
Joined
·
571 Posts
Discussion Starter · #4 ·
Thanks Kei for chimming in...its not that the power supply is bad, it just this PSU (Avance Technologies ATX12V-300SD) cause some serious interference with my Lamplinc. Can you recommend a non-Avance PSU to fit in the case or am I out of luck?


jidelite
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top