AVS Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hello all, I have been reading this forum for the last three years and enjoyed every minute of it. Now it’s time for me to contribute and ask for your help.


I have been using a Runco DTV-852 (Zenith PRO 900x) for the last five years (no I did not pay Runco's very high price for it) and it has been working great until now. It was not used for about two weeks and now The green CRT is on at a medium/low intensity with no video getting to it. Looking into the Red and Blue CRT's I can see an image but the Green is a blank raster. I am using the S-Video input (go easy on me with the jokes) and have tried a second DVD player just to rule that out. Using the setup remote I can blank the Red and Blue CRT's but the Green stays at the same intensity.


Any thoughts?


Thanks

Matt
 

·
Registered
Joined
·
18,501 Posts
1) Go into the test pattern with the service remote and see if the test patterns all come up equally.


2) If so, or even if not, open the case, and see the mini RCA connectors at the top of the RGB input board right over the controls on the back of the set. They are color coded. Swap the green RCA plug with one of the other colors. That will narrow it down to either the RGB board or the green CRT card. I can fix either one. New ones are hideously expensive.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
Thanks Curt, I swaped the Green and Blue connectors. Now I have video on the Green CRT and not the Blue CRT. Looks like the RGB Board is the problem.
 

·
Registered
Joined
·
18,501 Posts
Do you want to send it to me? It does come out, that whole input board assembly (2 boards actually) bolted to that whole metal frame along with the control panel. THere's a zillion 1/4" hex screws and the few Philips screws through the case.


Be sure to take out ALL of the hex screws before you yank on it, but the bottom connectors are pretty stiff, so it does take some force..


I probably won't be able to look at it until I get back from CES sometime after Jan 9...
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
Curt, I will pull out the RGB board this weekend. I will need to make arrangements with you to have the RGB board repaired.


Thanks

Matt
 

·
Registered
Joined
·
18,501 Posts
Thanks Matt, shoot me an email to my home address below.


I'll give you details on how to send it, and approx pricing to repair it.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #7
Curt


Thanks for the great repair service and quick turn around on my RGB board. My projector is back up and running.


Matt
 

·
Registered
Joined
·
18,501 Posts
Excellent, thanks!


THose Zenith/Runcos are a new challenge every time it seems. THe SMT transistors are either overstressed or the odd one goes bad after a period of time. The problem is, it's never the same transistor twice, and that board has about 75 of them on it..:(


BTW, on that set, S-video is fine, the internal doubler doubles it. HD with a transcoder into the RGB inputs looks very nice, I saw a well tweaked one in Seattle last year.


Curt
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top