AVS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, I have a new home theater that includes the following components:


- Denon AVR 891 receiver

- Samsung Series 8000 LED 3D TV 55"

- Energy Speakers & Sub (5 Ch)

- Motorolla DCX-3400 PVR

- PS3 Slim


I previously had the 890 receiver but upgraded to the 891 for the 3D capabilities (HDMI 1.4). I'm using HDMI certified cables that I just replaced (as a test to the following problem) everything goes through the receiver and receiver to TV.


I lose my picture every now and then, the screen goes black and then comes back. I don't lose sound. I've tried to troubleshoot the problem myself and have found that when I eliminate the receiver connections and go PVR to TV directly, I don't have the same problem. I've spent a lot of money and am frustrated beyond belief. Please help!


Thanks - P-Tell
 

·
Registered
Joined
·
22 Posts
Did you use the Denon 890 with the rest of the equipment you have listed above? If so did it have any problems? If that worked fine it might be a defect in the 891.


If you didn't use the 890 with all that stuff, try it out if you still have it and see what happens.
 

·
Registered
Joined
·
7 Posts
I am having a similar problem with between Sony KDL55NX810 55" Bravia 3D HDTV and Denon AVR-891.


The only difference is that I'm using a Siig Cat5 HDMI extender.


Any help would be greatly appreciated.


Thanks!
 

·
Registered
Joined
·
171 Posts
sounds like receiver all the way. I'd exchange it if you have the receipt and if it still does it return it and go a different manufacturer. sucks to hear the probs. I have a 890, but no 3D.
 

·
Registered
Joined
·
109 Posts
Just to dig up an older topic, I've had the same issue with the 891 and a Panasonic BDT300 BDP. In/out black video with perfect audio. I've tried to troubleshoot and change every setting on the receiver with no luck. BDP direct to TV works perfectly. I'm ready to return the 891 unless anyone has found a fix.
 
1 - 6 of 6 Posts
Top