AVS Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Hello,


I picked up a Samsung 58 PN58B650S1FXZA on Craig's List. The TV turns on and off and the display is not clear it has white spots.

I am not sure if its the power supply or one of the Y or Z boards. Can you help? Here is a pick of the tv screen.


I have tested


Va at 260-280 it should test at 202

Vs at 60 - 80 it should test at 55

Vsc tested OK at 190






BTW The image is clear for a second or two and then the white kicks in.
 

·
Registered
Joined
·
988 Posts
Do not run this TV any longer. The Va is too high and this can damage the plasma panel.

The high Vs is likely causing the plasma gas to maldischarge.


Get some pictures of inside the TV; I suspect the power supply is the issue.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·

Quote:
Originally Posted by tom669  /t/1468576/samsung-58-pn58b650s1fxza-help-needed#post_23214983


Do not run this TV any longer. The Va is too high and this can damage the plasma panel.

The high Vs is likely causing the plasma gas to maldischarge.


Get some pictures of inside the TV; I suspect the power supply is the issue.

I was only turning it on for a few minutes at time. I also suspected the power supply.

I have one coming in the next few days.


I'll keep you posted.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #6 ·

Quote:
Originally Posted by tom669  /t/1468576/samsung-58-pn58b650s1fxza-help-needed#post_23215136


If you're just going to swap the PSU, then wait for that to arrive and post back when it fixes it (or if it does not.)

Tom the first board I got was bad . I got a replacement but its for a 63" vs. 58" TV. All the connections line up but I don't want to install just yet because I am not sure its compatible.

Would you know?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #7 ·

Quote:
Originally Posted by str8maxn  /t/1468576/samsung-58-pn58b650s1fxza-help-needed#post_23237445


Tom the first board I got was bad . I got a replacement but its for a 63" vs. 58" TV. All the connections line up but I don't want to install just yet because I am not sure its compatible.

Would you know?

Tom,


I called Shop Jimmy dot com and they said it would work so I gave it shot. Well, it did work tv turns on the picture is great.

The Va and Ve tested OK



However, there is a slight hum coming from the X main board.

Not sure if I should be worried or not.

If so, should I replace the board now or what till it goes out?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #8 ·

Quote:
Originally Posted by str8maxn  /t/1468576/samsung-58-pn58b650s1fxza-help-needed#post_23237445


Tom the first board I got was bad . I got a replacement but its for a 63" vs. 58" TV. All the connections line up but I don't want to install just yet because I am not sure its compatible.

Would you know?

Tom,


I called Shop Jimmy dot com and they said it would work so I gave it shot. Well, it did work tv turns on the picture is great.

The Va and Ve tested OK



However, there is a slight hum coming from the X main board.

Not sure if I should be worried or not.

If so, should I replace the board now or what till it goes out?
 
1 - 8 of 8 Posts
Top