AVS Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello All. New to the forum & wanted to check with the experts about a problem with my Samsung HL-P5685W.

Was watching one evening of late; heard loud pop; set went black; set displayed lamp symbol on front; reset itself & restarted. When it came back up, only had B&W. I bought this set new & love it. Have replaced the lamp a couple of times since buying. One thing I did notice about the problem is that the whirring sound from the set is louder than normal ops (I'm making a big assumption here). I think the colorwheel shattered; thus causing higher rpm, making the sound louder. Wanted to check with the experts before ordering it. Have not tore into it yet. Could it be something else (color circuit board/other parts/?)?. Thanks in advance for any info/help.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Apparently I need to apologize for stumbling into an ANTI-DLP forum & making a post. I cannot find a way to "close/delete" post &/or profile & cancelling membership. I will take my question elsewhere. I did'nt discover the objective nature of dlp questions until I noticed the anti-dlp post. I would suggest that your site make it clear UPFRONT, that dlp questions are not wanted. I leave getting rid of my stuff to the forum admin. Sorry for your inconvenience.:confused:
 

·
Registered
Joined
·
2,224 Posts
This isn't an "anti-DLP" forum or anything of that sort. If anything, you've come to the right place. I would recommend looking for a thread for Samsung HLPxxxx DLP models in the same subforum.
 
1 - 3 of 3 Posts
Top