AVS Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter #1
Today i decided to take out an old sansui amp my dad bought in the 80s. It was store in the garage, which is freezing cold. Regardless, i hooked up to my NHT M6 for laugh and giggles, and i heard, and saw, some sparks from the sansui. No smoke though, but a faint smell.


The weird thing is that the amp was still playing music jsut fine, and my speakres were good too. I turn on and off the unit several times, but no issues what so ever.


So what happened? and is it still safe to use the amp?


I have been letting it play for the past 3hours at moderate to high volume, and can not replicate the issue. Was it from the dust buildup, or the freezing cold.
 

·
Registered
Joined
·
18,923 Posts
Definitely could have dust. You may not want to run it unattended, at least for awhile.
 

·
Registered
Joined
·
54 Posts
I would have a technician go through it just to be safe, and to give it a good cleaning. Needless to say if I ever saw sparks from an amplifier or other component, it would be immediately shut down and disconnected and taken right to the workbench. I would not keep running it for fear of damage to itself or to loudspeakers or to the house.


Even in the 80's Sansui made some fine integrated amplifiers, I'd have a tech give it a once-over if you want to keep using it.
 

·
Registered
Joined
·
928 Posts
You should have waited for the amp to warm up to room temperature before plugging it in. Ever heard of condensation or the fact water is conductive?
 

·
Registered
Joined
·
87 Posts
Discussion Starter #5
thanks guys, i appreciated. I was just overly bored and wanted to occupy myself. I should of let it warm up first.


so as you guys said, i should let it run..or should i just pay a techician to clean it up?
 

·
Registered
Joined
·
15,247 Posts
You could ask for a quote and see if it's to your liking. Otherwise, disconnect it, open it up, and vacuum out the insides, using a soft brush (take one of your wife's unused cosmetic brushes) to sweep things. What model do you have?
 

·
Registered
Joined
·
87 Posts
Discussion Starter #8
i actually opened the amp this morning to see whats inside. Apparently, there were very little dust and quite clean. However, what i found were what seems to be little brown insect legs (i know because i torture them when i was younger). I found like 4-5 of those lil brown legs. However,the body was no where to be found.


talk about CSI.
 
1 - 8 of 8 Posts
Top