AVS Forum banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
2,124 Posts
Discussion Starter · #1 ·
I just loaded Win 2K and everything works but my sound card. I load the drivers normally but it comes problems. It does not seem to recognize the drivers

Could someone tell me how to get this card working with Win 2k

I had no problems with Win 98. I have loaded the updated drivers from the creative website but it still does not work

Thanks

Steve
 

·
Registered
Joined
·
2,613 Posts
are you sure you have installed the correct drivers for your soundcard version?


As taken from the Creative webpage,


How to Identify Audio Products

SB Live! Identification


Including the Sound Blaster Live!, Value, MP3, Gamer, Platinum, and the 5.1 series.


To identify the model number of this sound card, first shut down the system in order to safely remove the card.

Once the card has been removed from the computer, examine the upper left corner of the component side of the card. This is the location of the model number (CT number). Here you will see the letters "CT" and four digits (e.g. CT-xxxx).

If further identification of the sound card is needed, turn the card over on its back and find the black ink stamp in the upper left-hand region.



Once you have done this, click on the link below and download the appropriate driver for your hardware

http://www.americas.creative.com/sup...sp?RD=download
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top