AVS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
253 Posts
Discussion Starter · #1 ·
I have a pair of Altec Lansing model 6-II's that I'm using as mains currently. There is a noticeable scratching noise coming from 1 of the midrange speakers. Most of the time it isn't really noticeable but specific songs or parts in movies get really annoying with this. I noticed today that adjusting the l-pad also creates a lot of this scratching noise, so it that a problem with the crossover or do I need a new speaker?


Thanks.
 

·
Registered
Joined
·
3,343 Posts
It sounds like the l-pad pot is corroding.


You should be able to fix it with some electrical contact cleaner.


If it is really bad off a replacement will be needed.
 

·
Registered
Joined
·
2,115 Posts
You may have two problems, but you definitely identified one.

You can try spraying some Caig DeOxit into the L-Pad to clean, de-oxydize and lubricate the contacts inside it.

If that doesn't work, you may need to replace the L-Pad.

Once you get the L-Pad problem resolved, that may very well be your only problem.


Hope this helps.


Soho beat me to it. That guy's fast.
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #4 ·
Thanks for the help guys, I will give that a try. These speakers were sitting in a garage for a while and the surrounds were beyond rotted out so they may not have been taken care of, but for the $20 I payed for them I am very pleased.


It's really not a big problem, for instance right now I am listening to Whiskey in the jar by Metallica and I can't hear anything wrong with them, but music like The six parts seven really make it apparent.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top