AVS Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
I am having a problem with my new home theater setup. I am running 5 Axiom speakers with a SVS sub and a HK525 all connected with RCA 14 guage wiring with gold connectors. The problem I have is that I get a scratchy sound on the diologue when someone is yelling in the media content (peak sounds). Now I thought it was a problem with the reciever so I got a replacement from J&R and still have the same problem. I also thought it was a problem with the speaker so I switched my center with one of the front surrounds and still get the same noise. I also tried new speaker wire and that didn't help. This noise happens on all sources, regular cable (analog) and DVD (digital coax). I am running out ideas on what it could be. The only things I can think of are dirty power fromt the wall or that the replacement reciever is bad as well. What do you guys think? I was thinking about buying a power conditioner and seeing if that fixes it. I can probably get another reciever fron J&R but I am only going to request it as a last resort. I am running out of time on the replacement window (10 days) so any quick help would be appreciated. Thanks everyone!
 

·
Registered
Joined
·
283 Posts
Chances are that it is in the recording itself. It drove me crazy several years ago until i realized it was not my equipment.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top