AVS Forum banner
Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 ·
Just picked up a 4700 last week. Two very odd things have cropped up as I've been playing with it. One, VERY annoying, one, no big deal.


1st the not so annoying. When I use the chapter skip buttons on the remote (used more lately cause I'm trying to find certian scenes to demo the player) about 75% of the time it turns on the subtitles. I've got to go to the DVD menu to turn the off then. Happens 100% of the time on Toy Story from the Ulitmate Toy Box.


2nd - so annoying I wanted to break something. My wife and I sat down to watch Life is Beautiful last night. When the DVD menu came up and I would try and navigate it with the joystick none of the menu items would highlight. Now, normally this would be no big deal, however, I don't know Italian which (in this case) would have been key to enjoying the movie. I couldn't get the **** subtitles on. I was able to guess where I was in the menus enough to get to the subtitles menu but no matter how many up or down clicks I couldn't get the subtitles to come on. Must've spent 1/2 an hour getting more and more angry. BTW: I went through the entire Tosh menu to try and figure if I didn't have something turned on right but everything seems set correctly.


Either of these every happen to any of you? Oh, the one thing I didn't think to try....chapter forward. That didn't occur to me until right now! Duh. Maybe that would have worked.


Other than that I absolutely love the player. Looks and sounds great - finally my TV is looking as good as I thought it could!


Thanks,


Brian.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top