AVS Forum banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
192 Posts
Discussion Starter · #1 ·
I was watching spiderman tonight and all of a sudden I heard a crack and my projector turned off. I pulled the bulb cage and it blew and the galss on the front of it cracked. Has anybody had this? It had 350 hours on it. I am unable to power the unit up now. Is this because the bulb is blown?


thanks,


Todd
 

·
Banned
Joined
·
946 Posts
Todd:


It is indeed very sad that this happened to you and that too on Thanksgiving Day. Is'nt the bulb guaranteed for a specific number of hours? Maybe you should check with Sharp and/or dealer.


I have read previous posts of this happening. The unit will not power up until the bulb is replaced.
 

·
Registered
Joined
·
97 Posts
Todd, can you tell me what happens with your blown bulb? I'm having a problem where when I apply power to the unit (plug it in) a single red led comes on, the power supply (I believe) clicks, and the led goes out. I assumed it wasn't the lamp as it looked ok and if the lamp was failing I would have seen the lamp replacement led come on and stay on.. what are you seeing with your system?


Thanks - Joe
 

·
Registered
Joined
·
192 Posts
Discussion Starter · #5 ·
I was watching spiderman and all of a sudden I heard a loud pop and the projector shut off. I pulled the lamp out and it appears to have cracked the glass on the front of the lamp cage.


todd
 

·
Registered
Joined
·
97 Posts
Todd, I guess my question is now with the blown lamp in or out what happens when you plug it in? Does the lamp led stay lit, etc.. thanks j
 

·
Registered
Joined
·
41 Posts
Jpresto,


I had the exact same symptoms on my Sharp a few months ago. I'm afraid it turned out that the power supply was fried and had to be replaced.


I have installed a line conditioner now, just in case.


Henning
 

·
Registered
Joined
·
97 Posts
Henning, thanks for the note. I'm actually glad it wasn't just the lamp, as I've already shipped back to Japan.


What line conditioner are you using?


Thanks - Joe
 

·
Registered
Joined
·
192 Posts
Discussion Starter · #12 ·
i replaced the bulb and it works now.. i am kind of wondering why i had a bulb blow at 268 hers. i just recently started using a cc30 filter in front if the lense. do you think the air flows throught the front of the projector and the filter is restrcting it? I dont know maybe it is just a coincidence?


todd
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top