AVS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi everyone, I have a Sharp Aquos LC52D92U. Purchased in late 2007, is just under 7 years old and it recently started displaying vertical lines intermittently. At first, the lines did not overlap the on screen menus, but now they do. Just wondering if anyone else has seen this behavior. I've read it could be the mainboard, power supply, TCON, loose ribbon cables and bad caps, which doesn't narrow it down much :)

Looking for suggestions and tips for diagnosing the problem. I do have an electronics background, but have not done TV / monitor repair. I have a DMM so I can check voltage levels and if it's something as simple as bad caps can do component level repair... If it's a bad IC (with densely clustered pins), I'd have to replace the board as my soldering skills aren't quite that good :) .

Any assistance is appreciated.

Here are some pictures of the problem:



 

·
Registered
Joined
·
4,389 Posts
Had the exact same problem with my D92, 3 years ago. Mine was very faint, sometimes you couldnt see it, sometimes you could. Never found out the problem so I sold it and thought it was a good excuse to get a new TV. You could try and find the boards and replace them yourself, try E-bay. Good luck.
 
  • Like
Reactions: Ernest Aleixandre

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks for the quick reply.... I've seen the mainboard mentioned many times... I was searching various parts stores that carry used TV parts online since they are usually a bit cheaper and carry a 3 to 6 month warranty.... I was finding the mainboard for $80 to $100 online (not bad), but EVERYONE is out of stock... Not a good sign LOL.... That's why I was hoping for bad caps... That I can fix....

Anyways... Thanks for the reply. :)
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top