AVS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
995 Posts
Discussion Starter · #1 ·
I've had a sharp xv-z12000 connected via the DVI to a sony blu-ray (bdp-s300, sony hdmi to sharp dvi input). The sony just died. I bought a new sony blu-ray and it wont talk over the hdmi to the sharp. Sony complains about not a valid hdmi device. So I took the new sony blu-ray back.


Are there any blu-rays that will work hdmi to dvi. Note: The sharp does not have HDMI input, just DVI. But Ive used it for 2 1/2 years like this (and via a computer with blu-ray and Any-DVD before that via dvi).


Sorry if this is not right forum, but i figured only you guys would know about the sharp xv-z12000.
 

·
Registered
Joined
·
12,276 Posts
Are you switching through a receiver or anything, or is it going direct? In theory if the BDP300 worked anything should. The error you are getting sounds like an HDCP error, but the 300 had HDCP as well. I wonder if that player you just bought might have been faulty, though it is possible the sensitivity is more than your old unit.
 

·
Registered
Joined
·
12,276 Posts

Quote:
Originally Posted by emf /forum/post/19559506

Check Setup


Your projector works with 720P. From your player Setup, select 720p. Your projector should tell the player it needs 720p, but sometimes handshake is a bit weak.

That is a good point...it is entirely possible that the new player came defaulted to 1080p, which the Sharp cannot recognize (some 720p units can accept 1080p and downconvert, but not the Sharp in question).
 

·
Registered
Joined
·
995 Posts
Discussion Starter · #5 ·

Quote:
Originally Posted by emf /forum/post/19559506

Check Setup


Your projector works with 720P. From your player Setup, select 720p. Your projector should tell the player it needs 720p, but sometimes handshake is a bit weak.

I believe that is what was it. I purchased a Samsung BD-C6500 for like $140. When I used the hdmi to DVI connection, the picture was lower resolution (but at least i has a picture).


Then I found a menu on the Samsung (that i could not find on the sony) to force the hdmi output to 720p.


Now all is well.


Thanks all for the help.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top