AVS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I'm new here, so I apologize if this is the wrong place to be posting this, but I've been driving myself crazy about this since Christmas, and I figured the people here could be some help.


Here's the system I have set up right now:


TV: Westinghouse W4207 42" LCD

HDMI Switch: MonoPrice HDX-401E (Rev 3.0)

A/V Receiver: RCA RT2600 (used for audio only)

PVR: TiVo Series 3, connected to TV via HDMI switch, connected to receiver via toslink optical cable

Blu-Ray: Panasonic DMP-BD35, connected directly to TV via HDMI-to-DVI, connected to receiver via toslink optical cable

Apple TV: Connected to TV via HDMI switch, connected to receiver through a toslink-to-digital coaxial converter


All of this is controlled by a Logitech Harmony 880 remote control.


I got the HDMI switch and Apple TV (and all necessary cables) on Christmas. Since then, I've been combating one issue after another, but I've managed to fix all of them except for one: When I'm watching TV through my TiVo, either live or recorded, the image briefly goes out, for maybe half a second, and comes back.


I thought I had tackled this problem twice, first by making sure the HDMI switch powers on first and the TV last, then by making it so that the HDMI switch is always on no matter what. But yesterday, the image was flickering once every few minutes (though it seemed to be only after I started watching a recorded program, and it continued when I just switched to the TiVo menus). It appears to happen about 40 percent of the time -- definitely enough to be incredibly annoying.


I've read this has something to do with "handshake" issues between the switch and my TV, but I don't know what to do about it. Interestingly, this never happens when I'm watching on the Apple TV, but it was so bad when using the Blu-Ray player that I just took it off HDMI entirely and use my TV's DVI connection.


I think the switch is the culprit here, but I'd like to hear if there are any other possibilities, as well as any suggestions for an HDMI switch that won't create these problems.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #2 ·
One addendum to this I discovered yesterday: The flickering while watching TiVo only happens if I switch over from watching the Apple TV. There's never a problem if I'm starting with the TV turned off.


Anyone have a solution? Maybe some way to program the remote to get around this?
 

·
Registered
Joined
·
7 Posts
I have the same switcher. My Xbox does the same thing on inputs 1&4, it has snow on 2 and sparkles on three. I can't get any of my source components to work right. I am waiting for them to get back to me with all of the hoops that I need to jump through. Unfortunately I waited a couple of months to hook it up, otherwise I would definitely return it.
 

·
Registered
Joined
·
732 Posts
If you haven't moved the cables around, swap the apple's HDMI cable with say the Tivo's, and see if the problems are reversed.. possibly swap ports too.


A cable might work fine between two devices but not between two others ... so they might just be marginal.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top