AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter · #1 ·
Hey all, as of a week ago my projector, a sim2 ht300 (which is a 1280x720 dlp) has started having a problem. I've been feeding it a 720p signal from my xbox360 and ps3 via component (this projector doesn't have hdmi) but the image has started flashing between the game/blu-ray and a black "No Signal" screen. I've never had this problem before in the year I've owned the projector and haven't changed any settings or anything in my setup. I've redone all cable connections to no avail. It certainly seems like the projector is no longer able to lock on to a 720p signal.


Has anyone seen this problem before on this or any other projector? Does it mean that some piece of electronics within the projector is likely dying? I'm guessing that it's basically at the end of the life of the projector and it's time to upgrade but if anyone has any ideas I'd love to hear them. Sim2 looks like it is going to be a bit of a pain to work with as far as getting it fixed and it seems like it won't be worth the repair cost to send it in.


Thanks very much for any advice!
 

·
Registered
Joined
·
935 Posts
If this is a specific Sim2 problem, you may want to also ask this question in the over $3000 forum. For under $3000, Sim2 has generally given you a brand new power cable, or perhaps even a set of component cables, but certainly not anything that resembles a full-blown projector.


Jim
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #3 ·
OK, I got the projector used for a steal so I had no idea how much it originally was. I'll give the other area a try. From poking around on the sim2 site though I get the impression that whatever is wrong with it won't be worth paying to fix it, they make it sound like I need to ship it off to Italy or something. If it's dying (which I think it is) then it's time to get a new one, like the Panasonic 3000.
 
1 - 3 of 3 Posts
Top