AVS Forum banner
Status
Not open for further replies.
1 - 20 of 21 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter · #1 ·
OK, now I have the connection refused problem. Luckily, I am at home and can do some troubleshooting.


I have two machines defined in my Slingbox directory. Both entries point to the same machine and port number, but they have different IP addresses. One has the public IP address, and one has the local network address (192.168.0.4).


If I use the local address, all is well, and I can see the Slingbox, and watch TV. If I use the public address, I get the following error:

No connection could be made because the target machine actively refused it.

Error: 0x8007274D


I checked the router, and the Slingbox is gone. Both lights on the Slingbox are solid green. I tried running the wizard and it could not find the Slingbox. I disconnected the network cable for 30 seconds and reconnected it, but it still would not pick up an address. I unplugged the power from Slingbox for 30 seconds, but it didn't help.


Note that even though the wizard can't find it, I can still watch it just fine, as long as I use the local network address.


I guess the next step is a total reset, but I'm holding off on that until morning.
 

·
Registered
Joined
·
43 Posts
Generally you will not be able to route from an internal address (your machine on your own LAN/wireless) to the external address if it's simply a forwarded port. If you can hit the internal IP, your SlingBox is fine. You can let the wizard verify external connectivity if you are curious (or just try the SlingBox from outside your network).
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #3 ·
Quote:
Originally Posted by pescador
Generally you will not be able to route from an internal address (your machine on your own LAN/wireless) to the external address if it's simply a forwarded port.
I was able to do this last week with no problem.


I did double-check the port-forwarding on the router, and it's fine. I've not touched the router setup since I installed the Slingbox.


I'll have to try with dial-up to confirm. I sure don't want to get to the hotel and find I have no Slingbox.
 

·
Registered
Joined
·
8 Posts
Quote:
Originally Posted by KenW
I was able to do this last week with no problem.


I did double-check the port-forwarding on the router, and it's fine. I've not touched the router setup since I installed the Slingbox.


I'll have to try with dial-up to confirm. I sure don't want to get to the hotel and find I have no Slingbox.
I have been receiving the same message. I even went out and purchased a new router and still have the same issue. When I try and view the box from outside I receive the same message. I am fine at home. I have port forwarded on my Linksys SRX router and the slingbox has come back with me doing all of the port forwarding and said it can access the internet and is configured for out of my network viewing. I have tried to have the box connect using the slingbox finder as well as using the IP address of my WAN. Both with no luck. I have been round and round with slingbox help and they feel it is a firewall issue. I do not feel the same because the software looks like it is trying to connect it even seems to find the box but says the box refuses the connection. I have opened the port of 5001 on my home norton firewall and have the latest software and firmware. I have also port forwarded my TIVO to 443 and I can connect to my TIVO with no problem over the same network.
 

·
Registered
Joined
·
239 Posts
saramj,


Could you try (temporarily) setting your TiVo to 5001 and your Slingbox to 443 and see what the results are? Please feel free to email me directly and we'll get to the bottom of it!


Best,

Jeremy
 

·
Registered
Joined
·
8 Posts
Quote:
Originally Posted by jtoeman
saramj,


Could you try (temporarily) setting your TiVo to 5001 and your Slingbox to 443 and see what the results are? Please feel free to email me directly and we'll get to the bottom of it!


Best,

Jeremy
I tried your suggestion and moved the slingbox to 443 and I can connect from anywhere with no problem! WHY?????? Is 443 a port that is already open on my PC and/or in my firewall? I thought I opened 5001 on my PC and firewall. Could my work firewall be blocking 5001 - who knows why? I do not think this is the cause because the box always looked like it wanted to connect but then I got the message. But switching the port forwarding to 443 works. I also could only connect using the sling finder. If I tried connecting using the WAN address I could not connect. My only problem now is the volume is VERY low. I have boosted all of the vilume controls on my laptop all of the way up. Still low. I am wondering if this is the tiny speaker on my laptop. Will try on my desktop in my office tomorrow with the speakers. I do not have this problem at home. I need to actually turn the speakers down.
 

·
Registered
Joined
·
511 Posts
Everybody has turned off Windows' firewall, right? Everyone has checked to make sure that Norton Internet Security isn't blocking them (again), right?
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #8 ·
My problem turned out to be a new VPN client. I'm still investigating what was broken.


Unfortunately as a consultant, I must use the software that the client requires. The challange comes when it breaks something I want to use.
 

·
Registered
Joined
·
261 Posts
After getting my new Slingbox set up at home, and turning on remote connection yesterday, I tried to install the software and connect at work today. Unfortunately, I am getting error message 0x9234006D. I tried connecting using the Finder and using direct IP (WAN IP) and port 5001. My Router is a Linksys BEFSR41 v2.0 with UPnP enabled.


I will try changing the port to 443 and see if that works. Unfortunately I will not be back in the office until next week, was looking forward to watching Over There today during lunch!
 

·
Registered
Joined
·
239 Posts
joeinma,


JFYI - that error code is a Windows error generated due to TCP/IP connection problems. It is likely due to a firewall or other network condition in your office. Let us know if changing the port works!


Best,

Jeremy
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #12 ·
Quote:
Originally Posted by jtoeman
May I ask what VPN client you were using?
Checkpoint VPN-1 SecureClient

NG with Application Intelligence - R56

Build Number: 269


I have found it works from the hotel, so it's just the local LAN that's blocked. I suspect a setting somewhere, but I've not had time to investigate.
 

·
Registered
Joined
·
110 Posts
Try reinstalling the client by completely removing then reinstalling, I found you need to do this whenever you reconfigure your router. Even if it works locally I found for the remote access this is necessary. Maybe slingbox will find a fix for this distracting problem.
 

·
Registered
Joined
·
6 Posts
I'm a realtive newbie to this. Can you enlighten me on how to "turn off Windows' firewall, and make sure that Norton Internet Security isn't blocking them (ports) that will let me "Sling through" without opening myself up to "attack" Thx
 

·
Registered
Joined
·
6 Posts
Quote:
Originally Posted by joeinma
After getting my new Slingbox set up at home, and turning on remote connection yesterday, I tried to install the software and connect at work today. Unfortunately, I am getting error message 0x9234006D. I tried connecting using the Finder and using direct IP (WAN IP) and port 5001. My Router is a Linksys BEFSR41 v2.0 with UPnP enabled.


I will try changing the port to 443 and see if that works. Unfortunately I will not be back in the office until next week, was looking forward to watching Over There today during lunch!
joeinma, I am getting same or similar message 0x9234006F so if you find out a solution can you let me know by either posting her or sending me an email. Would appreciate it
 

·
Registered
Joined
·
239 Posts
smithjay,


Are you trying to connect to your Slingbox from an office or other corporate network? Can you confirm your firewall settings will allow the SlingPlayer to connect?


Best,

Jeremy
 

·
Registered
Joined
·
261 Posts
I got my Slingbox to work at my office by switching from Port 5001 to Port 443. As per the instructions on the Sling Media web site, I changed the Port Forwarding on my Router, changed the the SlingBox set up to use semi-automatic UPnP and made sure that the new port was picked up in the SlingPlayer configuration.


I am getting 275 Kbps on average at work, which is obviously slow compared to the higher speeds when I am connecting directly via my home network. The video is fine when in a small box (docked to a corner), but not that good at an increased size.
 

·
Registered
Joined
·
365 Posts
Seemed like the appropriate place to report that I got SB remote working from within my corporate network using Windows small business server 2003 as the router/dhcp server. As with any multi-router setup, an appropriate port needs to be open all the way to the primary router which references the ip address of the next router upstream.


I've only had my SB running for a day, but I'm really impressed with Sling Media--particularly the support (real human beings) who answer the phone fast and know what the heck they're doing.


Todd/Indy
 

·
Registered
Joined
·
6 Posts
jtoeman,


yes trying to connect from office behind corporate firewall. Relative newbie so not sure how to "confirm your firewall settings will allow the SlingPlayer to connect?". Any suggestion on what to look for or how to confirm this. Thanks for your help, I appreciate it.
 

·
Registered
Joined
·
239 Posts
Quote:
Originally Posted by joeinma
I got my Slingbox to work at my office by switching from Port 5001 to Port 443. As per the instructions on the Sling Media web site, I changed the Port Forwarding on my Router, changed the the SlingBox set up to use semi-automatic UPnP and made sure that the new port was picked up in the SlingPlayer configuration.


I am getting 275 Kbps on average at work, which is obviously slow compared to the higher speeds when I am connecting directly via my home network. The video is fine when in a small box (docked to a corner), but not that good at an increased size.
joeinma,


Our engineers have found a way to improve our optimization algorithms further. We have a new firmware build coming soon, and I have a beta version available if you'd like to email me directly. If not, it'll be ready for distribution in the next few weeks (along with a slew of new fun features).


Best,

Jeremy
 
1 - 20 of 21 Posts
Status
Not open for further replies.
Top