AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
So I have a new LG 3D Smart TV (55LM6200) that replaced my failing Pioneer Elite plasma. There are some wonderful features on this new TV but a few drawbacks as well that we are learning to live with, however one problem I am having has to do with running apps on the tv and audio out. No matter what I do I can't get the audio from the TV to go thru my HT Receiver which is a Pioneer Elite SC-07. The only way to get any audio whatsoever if in App Mode is thru the TV speakers, in which case the signal from the TV shuts down the receiver.


My setup consists of:


DirectTV receiver connected to SC-07 thru HDMI.

PS3 Connected to SC-07 thru HDMI.

Optical out from TV to SC-07.

HDMI out from SC-07 to TV.


If I set the TV speakers to "on" then when I switch to an App program the receiver sees the signal, switches to "TV/SAT" and then shuts itself off.

If I set the TV speakers to "off", then when I switch to and App program the receiver sees the signal, switches to "TV/SAT" but no audio is present.


Any help greatly appreciated as there are some really good features on the Apps, such as Amazon Prime streaming that I would like to take full advantage of the HTTV experience.


Thanks in advance,

Dan
 

·
Registered
Joined
·
205 Posts
I can't offer any real help but I would start by disabling the hdmi control features (CEC or whatever propriatary name the manufacturers use). Also on my TV the audio out has to be set for digital out. Also are you using an audio return channel at the same time as the optical out? Lastly, is it possible that the optical cable is not wirking either due to defect or bend radius/connector engagement? I have heard of enough cases of trouble seating the connectors of an optical cable that I think it's worth checking again.
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #3 ·

Quote:
Originally Posted by scipper77  /t/1479561/smart-tv-apps-audio-not-switching-thru-to-ht-receiver#post_23481836


I can't offer any real help but I would start by disabling the hdmi control features (CEC or whatever propriatary name the manufacturers use). Also on my TV the audio out has to be set for digital out. Also are you using an audio return channel at the same time as the optical out? Lastly, is it possible that the optical cable is not wirking either due to defect or bend radius/connector engagement? I have heard of enough cases of trouble seating the connectors of an optical cable that I think it's worth checking again.

When you say disable the HDMI control I assume you mean on the receiver, because I haven't seen any options regarding HDMI on the TV other than input modes. I will try to disable HDMI control on the receiver and see what happens. My TV doesn't have a switchable "digital out" feature due to the only audio output is optical and therefore digital. I don't think the cable is defective as it came off the Pioneer plasma and was working just fine.


"Also are you using an audio return channel at the same time as the optical out?" - My receiver is not HDMI 1.4 capable so this feature is disabled on my TV.
 
1 - 3 of 3 Posts
Top