AVS Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I just bought a beautiful Sony KLV-46X200A 46" 1080p native LCD, X series Bravia, Sony's best quality screen here in New Zealand.


I plugged it into my brand new iMac via a DVI to HDMI cable and set the iMac to 1920 x 1080.


Nothing I do to the LCD will make it display the image as a perfect 1 to 1 mapping. The screen tells me it is recieving a 1080p signal.


When the screen is set to "Normal" wide mode it is displayed as a 4:3 image and there is a large black border (at least 3 inches) top and bottom and terrible pixel mapping of the fonts.


When the screen is set to "Full" wide mode the image is displayed at 16:9 and there is still a wide black border around all sides and the pixel mapping is just as bad.


So i borrowed a friends brand new Macbook Pro...... exactly the same result.


I only bought the screen to use with the computer.... I am gutted.


I also have an older dual G5 tower.. it only has a 64meg video card, but can still output 1080i... this signal was displayed exactly to the borders of the screen when in "Full" mode, but at 4:3 when in "Normal" mode. In both cases the pixel mapping is horrible.


In all these cases the screen seems to treat the input signal as 4:3... and then rescale it to 16:9 when told to go to "Full" wide mode


I have been told by Sony that "Normal" wide mode means that the bravia image processing engine does not do any scalling to the input signal, but how can that be? The graphics cards report 1920x1080 or 1920x1080i.



Lots of photos of the problem here

flickr /photos/cicada/sets/72157600263026515

(being a newby i am not allowed to make URLS link)


Has anybody had experience with this kind of behaviour? Any ideas how to fix it.... I don't want to return the screen... it's soooo nice... but what else can I do?



Cheers

Nick
 

·
Registered
Joined
·
1,329 Posts
Two things to try here, before jumping in with SwitchResX or DisplayConfigX.


1. Are you sure the Sony has a 1:1 pixel mode? Make sure you have that on.


2. In the Display System Preference window, there's a button called "overscan". Try messing with that to see if it does anything.


Good Luck!


ft
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanks ftaok,


I found both the 1:1 pixel mapping... and the overscan adjustment, neither fixed the problem.


It may be an issue with the long cable, it's over 10m... have you ever seen symptoms of a too long DVI/HDMI cable?



Nick
 

·
Registered
Joined
·
283 Posts
Hi Nick,


If the x series is the same as the XBR2/3 in the U.S. then I recommend using a VGA cable and the VGA connection on the TV. I used a DVI to VGA adapter & a long VGA cable with my Mac Pro (Radeon x1900) and got perfect 1:1 without any adjustments on a 40" XBR2.


With your imac you can do the same thing. Just buy a cheap little DVI to VGA adapter (you may already have one as they usually come with video cards) and then run a VGA cable to the TV. You should get perfect 1:1.


From what I have read on these forums, trying to use the HDMI or DVI connections on HDTVs usually involves a lot of tweaking and 3rd party apps. I prefer not to have apps like switchres running in the background. A VGA cable will achieve 1:1 and it will look fantastic. Good luck.
 

·
Registered
Joined
·
605 Posts
I have the 40" XBR2. Display Area = Full Pixel. Accepts 1080p from my MacBook DVI to HDMI perfectly. It required a restart for the computer to recognize the display. I'm not sure that the non-XBR series has the "Full Pixel" option.
 

·
Registered
Joined
·
283 Posts

Quote:
Originally Posted by tommylotto /forum/post/0


I have the 40" XBR2. Display Area = Full Pixel. Accepts 1080p from my MacBook DVI to HDMI perfectly. It required a restart for the computer to recognize the display. I'm not sure that the non-XBR series has the "Full Pixel" option.

Restarting is definitely something to try. Since people in the U.S. can get 1:1 over HDMI, and OP has tried it with a Macbook Pro and it didn't work maybe the X series in New Zealand is different. Try VGA and see what happens. VGA is simpler (at its heart it is just component really) and since the TV has a specific PC setting in the VGA menu maybe it is better designed to accept a signal from a computer over VGA.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·

Quote:
Originally Posted by roblim /forum/post/0


Restarting is definitely something to try. Since people in the U.S. can get 1:1 over HDMI, and OP has tried it with a Macbook Pro and it didn't work maybe the X series in New Zealand is different. Try VGA and see what happens. VGA is simpler (at its heart it is just component really) and since the TV has a specific PC setting in the VGA menu maybe it is better designed to accept a signal from a computer over VGA.

from the manual higest res VGA mode is


WXGA 1280 768 47.4 60 VESA

1280 768 47.8 60 VESA

1360 768 47.7 60 VESA


so no better than 1360x768 over VGA..... no chance of 1:1


and this makes me really suspicious... (from the manual)


The HDMI jacks only support the following video inputs: 480i,

480p, 576i, 576p, 720p, 1080i and 1080p. To connect a PC, use the

PC IN jacks.


Maybe it will only accept full res signals from devices capable of outputting HDCP...... AKA it will play unencrypted signals.. but only from a device which goes through the intial HDCP handshake.... just an idea..


just to recap....my bravia is doing this




more images with more detail here
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
all the differnet machines have been restarted dozens of times... i have some decent help here.... ALL settings on the MACs and the screen have been adjusted ad-nausea... to no avail..
 

·
Registered
Joined
·
1,353 Posts
I read an article a couple of weeks ago (sorry I don't have the link available) that said the length of the HDMI cable can be a big problem. I don't know off-hand what the maximum length they recommended. Perhaps you can try moving the computer and HDTV closer together and trying a shorter cable. Good luck.
 

·
Registered
Joined
·
283 Posts
Based on the manual and OP's experience, it sounds like sony omitted 1:1 pixel mapping on the KLV-46X200A over either VGA or HDMI (from a PC). That is really unbelievable, especially on such a high end TV. It sounds like the only other option is tweaking display settings with either SwitchResX or DisplayConfigX. Both programs let you adjust the video signal in many ways, maybe you can convince the TV to let you do 1:1 over HDMI. good luck
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top