AVS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
Contact your dealer and get a new unit. There is something severely wrong with yours. It looks like the green LCoS chip has shifted considerably inside the light engine.
i bought this unit last year. but dint really opened it till today.
as my frnd bought is online last year it difficult to find out the dealer online.
are they any other options to fix it.
 

·
Banned
Joined
·
10,827 Posts
This issue looks to be with the projector's hardware, not a software failure. It isn't something you can fix by using the projector's menu system. I would imagine the only way to fix it is to replace the light engine inside the projector. If there is no warranty option available then you could try to send it in to a repair center and pay to have it fixed outright.
 

·
Registered
Joined
·
21,006 Posts
i bought this unit last year. but dint really opened it till today.
as my frnd bought is online last year it difficult to find out the dealer online.
are they any other options to fix it.

Sorry to say, this is why one should always buy from a reputable dealer, and never buy a projector you aren't going to use right away. Surely you have a bill of sale or receipt for such an expensive purchase, with the sellers information.
 

·
Registered
Joined
·
9,622 Posts
i bought this unit last year. but dint really opened it till today.
as my frnd bought is online last year it difficult to find out the dealer online.
are they any other options to fix it.
Wow that is very unfortunate, and highlights the fact that if you buy such a delicate piece of electronics it should be tested right away not put into storage for months... You might have some difficulty getting it repaired under warranty if you bought it from a non Sony-approved dealer.
 
1 - 6 of 6 Posts
Top