AVS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a Sony Bravia KDL 40W4100 that I believe the power supply is gone on. When plugged in it gives me a double blink on the standby light. Which it looks like it means I need a new powersupply. Is this correct? And if so where do I get one?
 

·
Registered
Joined
·
2,615 Posts
Could be the power supply or just the capacitors which you can replace if you can solder. Do some searches with the make and model + bad capacitors for more info.


Samsung has been replacing their defective power boards for free out of warranty, call Sony and see what their policy is.
 

·
Registered
Joined
·
278 Posts
With a little knowledge in electronics and a multimeter, you can easily check out the power supply. Using the meter, verify that all the required voltages are present. See post #7 at:

http://www.avsforum.com/avs-vb/showt...ighlight=power


The voltage outputs are where the connectors attach and their levels should be silk screened on the circuit board.


I recently repaired 3 TVs, which in every case was a blown fuse in one the the low voltage circuits (50 cent item).


Since you did not mention otherwise, the above assumes you have no picture and audio.


If you have audio , but no picture.....more likely an issue with the 18 volt section of the power supply or the inverter board.
 

·
Registered
Joined
·
121 Posts
Hey Slepthien,


My name is mike I work with the sonylistens team, I'm sorry to read of your trouble with your TV and want to help. Please call 800-222-7669 and explain what going on with the TV to them and they should be able to help. If that does not help please email your model and serial number to [email protected] and we will have the TV evaluated and work towards resolving this issue asap.


Thanks,


Mike Puma
 
1 - 4 of 4 Posts
Top