AVS Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
My three yr old Mits 73903 has 5 connector RGBHV connection. Question: To connect from HD200 can i use a 15 pin cable to the RGB out with the 5 BNC plugs for the TV on the other end OR must I convert the componet (3) out to VGA (5) with hardware like a KEYDIGITAL KD-CTCA2. Am I going about this the right way??
 

·
Registered
Joined
·
532 Posts
The VGA breakout cable will work just fine. Of course you will also need 5 BNC-RCA adapters. I use this hookup to my Mitsubishi WS-55905 since I invested in a high end RGB cable when I had the DTC-100.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
If I understand the answer correctly. I can go from the Sony HD-200 RGB out 15 pin connecter thru a breakout cable to the 5 RGBHV BNC connectors and this will provide all of the sat receiver video connection I need.


The dealer also suggested that I could use the KeyDigital box at $350 to convert from 3 wire componet YPbPs to 15 pin VGS to the same breakout cable:RGBHV with BNC connectors for the back of the mits


I ask because plan A above does not appear to work. will try again given this posting.
 

·
Registered
Joined
·
532 Posts
I seem to remember that the 1st generation Mitsubishi HDTV sets required a service menu setting to switch between Component and RGB. You could get a definite answer at ***************.com.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
On my mitsubishi I have 3 S video, V, L, R,,a DVD Video:YCrCb, and a high definition interface RGBHV with L and R audio and a HDTV control 15 pin connector that was for orginal mits HDTV receiver. I will look to see if there is a service menu option for the HD interface.
 

·
Registered
Joined
·
611 Posts
On my Mits I had to go to 'assign input' in the setup menu, then change the DTV input from "RGB" to "YPrPb" when I upgraded from the old Mits HD OTA only box to the SR-HD5.


As an added twist, when I first tried to do that the option was not available on the menu. After about an hour on the phone to two different Mits numbers I was told that I had to reset the TV by disconnecting it from the power for five minutes... after that all was fine.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
In the mits set up menu I cannot find any references to DTV (except turning on DTV Channel Guide). The book is not clear since it was written for the Mits 1gen set top box. It implies that the input select button will move from ANT A to ANT B to DTV, to INPUT 1, INPUT 2, INPUT 3, INPUT 4 then loop around. It never shows a DTV input. ONLY A, B, then 1 thru 4.


I get a video signal only on ANT A (analog OTA) and input 1 from my AV receiver. I am coming out of HD 200 15 pin RGB with a 5 wire breakout cable to RGBHV on the back of the mits -- but no signal seems to make it to the screen except via the S plug into input 1 at 480i.


any suggestions?
 

·
Registered
Joined
·
89 Posts
Lets see if I can help. There is a procedure to activate the DTV input on the Mits xxx03 series TVs. As I understand it, unless you use the 15-pin connector under the DTV input the TV will not recognize anything hooked to that input.


Try this: Hookup the 5 BNC cables to the appropriate connectors on the DTV Input on the TV. Have the STB powered up and it's HD output (1080i only) enabled.


(on the remote)

Press MENU, then 1 3 7 0 in succession

Use UP/DOWN ADJ button to scroll down to DTV

Press ENTER repeatedly till you see HD appear on the right

Press MENU twice to exit.

CAUTION: DO NOT ADJUST or CHANGE any other items in the Service Menu. It can render your TV useless!!


If the above fails, keep the hookup, keep STB powered up, turn off TV, unplug TV from wall outlet, wait 2 minutes, plug TV to wall outlet, power up TV. The TV should recognize the presence of the STB on the DTV input....hopefully.


Good luck!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Thanks - the service menu approach did the trick and I now have HD input recognized by the TV and am watching both OTA and Directv HD. I did make a mistake and mistakenly reset convergence in the service menu. I have reconverged and gotten the colors to match but still have barrel distortion. The convergence matrix is bowed. Now to find out how to fix this problem.


l
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top