AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I'm having a problem with my 2+ year old Sony STR-DG820 receiver... and I believe it's been this was since the unit was new.


I can calibrate and configure the system without any problems, and it works fine BUT if someone hits the power button on the front of the unit, or there's a power interruption (even for just one second), all the settings get lost. Speakers get set back to 2.0, calibration is reset, etc...


The odd thing is that some of the names I've put on the inputs do NOT get reset. For example, my SAT input is named "Cable TV" and that name does not get lost.


I've read the manual a dozen times and tried putting in and saving settings different ways but it's made no difference.


Does anyone have any idea as to what is happening? Can someone with one of these units hit their power button and see if the speaker setup gets forgotten?


[edit] I just found the "initialize" function in the users manual... Power off, Hold down "Tone" and "2CH/A.DIRECT", power on. This does not show "Clearing" like the manual says it should. It simply causes the unit to reset after a few seconds. Nothing ever shows up on the display while I'm holding these buttons.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Turns out it was a faulty microcontroller board. Replaced under warranty and it's running fine!


...added bonus, I got the firmware updated to the latest version. Fixes some HDMI issues.


This was the easiest warranty repair I've ever had to do.

 
1 - 3 of 3 Posts
Top