AVS Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
I have had this unit for a few years now and she has run really great for me. However for the last few months some strange things have gone on. At first when it was running for more than 2 hours straight, if a picture from a DVD for VCR has a bright light of white in it eg. a scene with camera flashing, the entire screen would shrink into a little grey box for a brief second and then spring back to full screen again. After a while (a month or two) it seemed to have stopped doing that but the blue tube lost its brightness heaps (almost nothin'). I thought it was dying on me but just last night the blue tube came back to life after it had been left on for an hour or two. So turned the unit off, screwed the board back in and put the cover back on so I could start converging agian (no i havnt memorized what screw does what) but when I turned it back on the blue lost all its brightness again :( I thought I would leave it on for a while so I left it for about an hour but had no luck.


Is my blue tube still alive? Am I doing something wrong? Is there a magical switch or button that fixes my troubles? (I hope)


BTW the unit is mounted to the ceiling if that makes any difference.
 

·
Registered
Joined
·
3,480 Posts
This may be a good time to upgrade. You have gotten a lot of use out of the PJ and if you can not find the problem, it might make sense to buy a better one instead of taking that one to the shop. Otherwise I would check all the connections, look for something that does not look right and wiggle things around as it is running, to see if there is a loose connection.


Deron
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #3 ·
Cheers for that quick response deronmoped. I have already been tinkering around with whatever I can find. I thought it might have been overheating at one point so since then and up untill last night I have left the cover off and unscrewed the board to let it hang. Didnt make any real difference though I dont think. I did drown the PJ in some of that freeze spray stuff to see what happened too. Oh yeh I just remembers something!!! There is a strange buzzing sound that occurs when the PJ picture shrinks to a grey box and then springs out again. Couldnt locate specifically where the sound was but man did it buzz.
 

·
Registered
Joined
·
18,503 Posts
The power supply is likely to die in this set. Give it a rest, it's from 1984; that's like a car with 200,000 miles on it.


(Trust me I know this story, my 1993 Toyota with 200K mi on it is finally giving up the ghost..:)


If you want to tinker, replace the 400 uF @ 350V cap in the power supply.


The intermittent blue is due to a bad module contact on the boards between the green and blue (or red) tube. Flip up the convergence and deflection boards covering the tubes, pull the two vertical boards out that are under them, and clean the contacts.


Curt
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top