AVS Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1 (Edited)
Situation:
My CDP, SACD player and DVD player are all failing this year so I decided to get a brand new universal player. Sony UDP-X1100ES. I now need to feed this into my venerable DVDO iscan VP50 to get it to my display, a Sony HD CRT.

Signal chain:
Sony UDP > HDMI > DVDO iscan VP50 > RGBHV > Sony KVHR-M36 wide CRT

Initial Settings:
UDP all display settings at auto except for 4K upscaling which is set to "off".
VP50 - Factory default/Analogue HD out/SVGA resolution

Limited success:
I know the CRT can display a signal from the UDP, even playing back a UHD disc, because I can get it to momentarily display one. Basically when I engage the VP50 it picks up the signal for a few seconds, displays it (gorgeously) and then gray vertical bars converge to the centre and the picture disappears. The power light on the VP50 then flashes until I turn on HDCP mode, then the picture goes black and the flashing light ceases. Turning off HDCP mode gives me the same cycle as switching on initially, a momentary picture before it is eaten up by converging vertical gray bars. I think I've been through most other settings in the input stage mutliple times to see if I can get a different result. I can't. I figure I have got it set to display properly, it's just a matter of holding that picture.

Humble request:
Could anyone please recommend any settings (frame rate? or other?) that could make the VP50 hold/lock the picture from the UDP? Thank you.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2
I've heard an HDFury box might fix my problem. Only thing is they're not cheap and I just dropped crazy reseller prices on the Sony. Any recommendations for a cheaper alternative to say an HDFury Integral 2?
 
1 - 2 of 2 Posts
Top