AVS Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
My Golden Theater Pre/Pro has stopped working. Anyone on the forum know of a source for schematics or someone that can work on one?


Any other service info would be appreciated.


Thanks...

Gary
 

·
Registered
Joined
·
198 Posts
Wow another Golden Theater owner. I thought that I was the last one.

Did you get it fixed? I too am interested in any service info for the GTX-1.

When they were in business I had several conversations with the creator of the unit. One of our topics was repair. According to Chris the engineer the unit was assembled with off the shelf parts. I would imagine that the biggest fear is the Eprom. Probably no chance of repairing the unit if its OP code was fried.

What is/was the unit not doing? Im keeping my fingers crossed with my unit because I don't think that I could get such good sound for that price new.


Rob
 

·
Registered
Joined
·
7,335 Posts
My first HT processor was a Golden Theater -- it's truly a shame that they folded as it was a great sounding unit for the money, and unlike many other processors, the back panel actually had room for those that have a penchant for audiophile cables ;)


They were just about to release an upgrade to the GTX-1 which would have been a tube based gain stage.


Depending on what's failed, it should be repairable -- the question is... what failed?


Regards,
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top