AVS Forum banner
  • Our native mobile app has a new name: Fora Communities. Learn more.

spdif issues: no sound, or sound lasts 2s

475 Views 8 Replies 3 Participants Last post by  BangoO
Hi there,

I'm fighting with my "DFI LanParty nF4 SLI-DR Expert" to output digital sound via spdif (Windows XP SP2).

It's a Realtek ALC850, and I know there have been some issues with XP SP2, but I can't find a solution !

I tried the Realtek drivers (3 of them including the very last ones).

The jumper is correctly set on the mainboard to output via the Realtek.

I have no sound at all on my receiver !

I also tried installing the NForce Audio Drivers (latest).

I have sound on the spdif (the receiver now displays 5.1 channels and goes to digital mode), but it lasts for 1 second and then my receiver goes back to "analog" and no sound.

If I pause the movie and restart it, I get 1s of sound again... same if I seek.

The jumper is of course correctly set on the mainboard to output via the NVidia.

I really don't know what to try anymore... so any help will be greatly appreciated !

Thx ! ;)
See less See more
Not open for further replies.
1 - 9 of 9 Posts
Operating sysytem?

Software player?

Decoders, audio renderer?

More info would be helpful.
As I said, Windows XP SP2 ;)

Any software player, any audio renderer... it's a general problem with the spdif output.

My receiver is a Denon AVCA1D.

I had the same issue with my other PC (Asus P4C800-E DLX), the lock on the receiver was lost after 2s of playback. I had fixed the problem with a driver upgrade.

But on this PC, I tried all the drivers I could find, none of them fixed the problem :(

Oh and I forgot one thing... with the Realtek drivers, if I go in the Windows Volume Control and display spdif, it appears greyed out...

Of course, it is not greyed out when I use the NVidia drivers, but the sound last 2s :D

PS: I test with TheaterTek and/or ffdshow audio, wave or directsound, ReClock or not...
See less See more
If the spdif option is greyed out, then you have a driver issue.

If I remember correctly, a member had the same issue and had to revert to the oldest driver, maybe one that came w/ the CD.

You could do a search in this forum on Realtek and your mainboard web site support.

Sorry I can't be much help.
Thx miketech, but I did all that already :(
A friend of mine has another mainboard, but also with a Realtek ALC850 chipset.

It works fine, and the spdif is also greyed out in the Windows Volume Control... so I have to look in another direction...
Have you tried setting your speaker options to 5.1 in Windows? I know this should have nothing to do with S/PDIF out but a friend had a similar issue that was resolved by this. Also onboard Realtek audio, on an Asus board. We tried everything and all multichannel sound (DD or DTS) kept cutting out after 2 secs. He called me later to tell me he'd set the Windows speaker config to 5.1 (although he's only using digital out) and suddenly his S/PDIF passed DD and DTS ok.
I'll try that again with the NVidia drivers then.

I know I tried it at some point, but maybe it was with the Realtek drivers... thx !
Ok I just tried... like the other time, when I install the NForce drivers, the sounds works perfect the 15 first minutes.

Then I start to loose the sound for a few secs and it automatically comes back.

Then, I loose it everytime after 2s and it never comes back unless I pause+play.

I tried setting the speakers to 5.1, it does not change a thing :(
1 - 9 of 9 Posts
Not open for further replies.