AVS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
Hey, Im a newbie when it comes to speakers, but you guys have really helped me get into the world of audio as the guys over in the Display's section have helped me to get into displays. Anyways I went searching for the insignia's everyone has been talking about and I have to say Im really surprised.


But.


I noticed that the left speaker now puts out this "zzzz" rattle or buzz sound at specific frequencies. The other speaker is fine, even switched them and it was still just that speaker doing it. When I touch speaker the rattle/buzz stops. I tried pushing on the speaker and I think I can hear it rubbing but I cant tell if its just un-even pressure or something.


What can I do about this? Do I call their warranty number? Is there an easy fix? Thanks everyone for helping out the new guy.


EDIT: I should add that this only is an issue at loud levels, but not too loud, like 25+ on my onkyo receiver.
 

·
Registered
Joined
·
1 Posts
Did your speakers come with the 'speaker spikes' and do you have them attached to the bottom of the speakers? They prevent vibrations and the floor from becoming speakers since they minimize the speaker/floor contact.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #3 ·
Ya they have the little feet on them, one is sitting on a bookshelf and the other is sitting on my table thing next to the couch. I switched theyre places and its just that speaker regaurdless of its location that has the issue. Seems weird to me that it would just be one, I mean I dont even play them loud.
 

·
Registered
Joined
·
469 Posts
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top