AVS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello everyone,
I have a kit 2.1 for PC which I replaced the original satellites, at beginning I used a RCA cable with adapter RCA-jack
and everything worked well, now I tried to buy a cable jack rca
and now I have a small "problem" I hear a buzzing noise coming from the speakers when nothing is playing ... how come it only happens with this cable?
thank you
 

Attachments

·
Registered
Joined
·
5,155 Posts
Originally you had the adapter on the Right, and you used RCA cables from the adapter to the amp?

Yes or no?

Then you switched to the cable on the Left, and you have buzzing? Is it buzzing or it it HUM?

Depending on the quality, it is possible that the Shielding in the new cable is not as strong as the cable you previously were using.

It is equally possible that you have a poor ground connections. Make sure the outer shell of the RCA connector is making contact with the ground on the amp.

Steve/bluewizard
 

·
Registered
Joined
·
5,155 Posts
If the existing connections have tight clean ground connections, and you still get hum. Then it is possible that the cable is poor quality. A generally better cable will have generally better shielding, and should stop hum. But first make sure the shield aspect of the RCA connector is making good contact with the Amp connector.

I typically bite them a bit, to squeeze the outer ring or 'flower' tighter so it make better contact, though don't over do it.

Without actually being there it is difficult to know precisely what the problem is, but given the same equipment worked before, and now doesn't work with this cable, it seems likely the problem is the cable.

A quality replacement cable need not cost a fortune. Consider something like this -

http://www.crutchfield.com/p_1426RCA35A/Scosche-Mini-to-RCA-Cable.html

http://www.crutchfield.com/p_120RCA356/T-Spec-Adapter-Cable.html

Steve/bluewizard
 
1 - 5 of 5 Posts
Top