AVS Forum banner

Stuttering with 1080p24

1596 Views 7 Replies 7 Participants Last post by  cameronl
Ok my specs are:

Windows 7 build 7229

Dell 24" (primary monitor DVI)

Sony 40V4000 (secondary monitor DVI -> HDMI)

Core i7 920

GTX 280 (with newset drivers)

12GB Ram

X-Fi Titanium 7.1 analog out

I'm playing MKVs with FLAC. I'm using BSPlayer.

Firstly, I have a problem where movies will stutter constantly whenever Aero is NOT disabled. In Windows 7, EVR renderer doesn't disable Aero anymore, and therefore stutters. Trying to manually disable Aero just causes tearing. The same goes for any VMR7 or 9 renderer, doesn't disable Aero.

The only two renderers which seem to disable Aero are Internal Overlay Renderer and Overlay Mixer.

I'm using Reclock with WASAPI Exclusive, which works well. I'm also outputting 24hz to my Sony 40" 1080p screen. Reclock does CINEMA adaption to convert the 23.976 to 24hz, to prevent the stutter you get every 30 seconds or so if it is left at 23.976.

I'm having to use the Overlay Mixer renderer instead of Internal BSplayer renderer, because with the Internal, Reclock doesn't detect the framerate 95% of the time, it just says "No video stream found", and can't sync to 24hz. Overlay Mixer always shows the resolution and framerate etc so there's no problem.

Now my actual problem is - using the Overlay Mixer and BSPlayer works well for about 30mins or so. Then it will randomly start to stutter after that long length of time being fine. The way to fix it is to press pause, then play. Then it will be fine for another 20 minutes, or 1 hour, or however long it is before it decides to start stuttering again.

So my questions are:

1) Is this stuttering problem related to playing the movies on a secondary monitor?

2) Does anyone else get jerky playback straight away when Aero is NOT disabled for any renderer? Seems to be that way for me.

3) Is there any way to fix this stuttering with my current solution of Overlay Mixer?

4) Should "Slave reference clock to audio" be ticked or not? It currently isnt.

If I switch back to 60hz there isn't any problem. It's trouble-free. So if there isn't any solution to these 24hz issues, I'll just go back to 60hz. I still get the stuttering when Aero IS enabled though, that seems to be a general thing for me. Because of that reason, I liked how Vista disabled Aero for EVR renderer, Windows 7 doesn't
See less See more
1 - 8 of 8 Posts
With my XP, I don't get shuttering video ... but I get lots of tearing.

I've tried every single renderer on MPC(HC) and still get the tearing.

Sorry, can't help ... just sharing my own experience with 1080p24.
See less See more
I use MPC-HC for playback of mkv files on my machine through to a the VPL-HW10 sony projector. I use either Haali/EVR renderer WITH aero enabled (Vista) and have no such problems (no tearing or stuttering). I'm using 24Hz output too (their is the occassional judder on panning shots but aside from that all looks smooth). I beleive it is only commercial soft (don't know about BSplayer) that disables aero, MPC-HC doesn't do that by default (again under Vista). My first thought is a driver issue, your machine is way powerful for any HD playback, have you tried turning of HA for your vid card? This may do the trick ofloading everything to the CPU. If that is not it perhapse a change of driver.

Hope that helps, let us know how you get on.


Also - if your driver offers a 23Hz setting, select that over 24Hz to avoid microstuttering.

Almost all "24p" content is actually 23.976p (because of the US shifting their TV field-rate from 60Hz to 59.94Hz in the 50s when NTSC colour was introduced, to avoid sound carrier interference from the chroma subcarrier, and that 59.94Hz rate has remained to this day even in HDTV for SD compatibility) Most driver manufacturers label their 23.976Hz mode 23Hz (as they only quote integer rates)

If you run at a 24Hz refresh rate and play 23.976Hz Blu-ray (or other) content - some frames will have to be repeated every so often - giving microstuttering.

This may not be what you are seeing - it is quite subtle - but it is another thing to be aware of in systems where you can't iron out the final bit of stutter.

(If you don't have a "24p" compatible display and have to use 3:2 pull-down then use 59Hz - which outputs at 59.94Hz which is the 3:2 multiple of 23.976Hz - rather than 60Hz to avoid microstuttering in that situation)
See less See more
madVR and Reclock works perfectly smoothly for me.

I mean PERFECTLY smoothly. And yes, it's on a secondary monitor, on vista, no aero.

Do the specs for both of your monitors state that they will accept 1080p/24 in addition to 1080p/60?

Are your montors able to refresh at any refresh rate other then 60Hz? If yes it appears that you have it set to refresh at 60 Hz and not at a rate that would provide judder free support with 1080p/24 input.
Thanks for the suggestions, someone on Slysoft forum suggested that my problem with the stuttering beginning after 20mins-1hr with Overlay Mixer (which is the best renderer in BSPlayer for me) is related to the Vsync Reclock adjustment. I've adjusted the Vsync correction and I *think* I've fixed it, will have to watch a movie right through to confirm though.

As for madVR, is there any way to use it with BSPlayer? I've installed it but can't select it from the BSPlayer options as a renderer to use. There are a couple of reasons I can't use other players, it has to be BSPlayer.

@sneals2000, I have tried both 23hz and 24hz and Reclock says the refresh rate is 24.000 for both of those, so I don't think there is any difference.

@walford, my Dell 24" only accepts 60hz, my Sony 40V4000 accepts 24hz, 50hz, and 60hz. The 24hz input does improve the smoothness, most obvious during credits. I do prefer it over the 60hz, but my Sony isn't a 120hz screen, so I think it is internally converting the 24hz back to 60hz, but the results are better than direct 60hz input.

It's interesting though, while pans are way smoother and so are credits (they are now smooth instead of jumping like they do with 60hz), sometimes when actors are moving close to the screen, they appear to flicker more than with 60hz. It's hard to describe. So I think the TV isn't doing a *perfect* job with the 24hz input, but I still prefer it to direct 60hz. It is probably applying it's own 3:2 pulldown, but it is still superior to direct 60hz. So tonight I'll watch a movie right through and make sure that the Vsync correction I did has fixed the 24hz to have perfect playback all the way through.
See less See more
hi, I get no stuttering with my 9600gt.

I set my refresh rate to 24hz and use reclock.

1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.