AVS Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·

I purchased this TV hoping I could repair it and use it in my man cave.  I knew the TV wouldn't power on when I bought it, but I figured $100 was a fair price to see if I could make it work.  When I got it home and plugged it in, the red LED powered up but no screen image and none of the buttons worked on the TV or Remote, and I couldn't turn it back off without unplugging the cord.  After reviewing the issue online, I plugged it back in, turned it on, waited for the red LED to appear, and then held the Power Button on the unit in for 5 seconds or so and that's when I first got the 14 blinks.  Downloaded the service manual for this model and discovered the 14 blinks was related to a faulty main board.  I ordered a replacement board off eBay for $75 and hooked it all up.  Now instead of a blinking LED, I get no LED at all but a relay that clicks every 7-8 seconds or so.  Just to experiment I hooked up the old main board to the set, powered it up and got the blinking LED again.  Re-connected the replacement board and still just the clicking relay with no LED.

 

I'm not a technician and I don't own a voltmeter, but it seems to me if there were an issue with the power, I wouldn't be getting any LED or relay clicking at all.  I'm wondering if I purchased a bad replacement board, or if it could simply be a blown fuse (there are 5 of them, all ceramic).  The service manual isn't much help in this area and the fuses aren't held in by clips but by end-caps which I'm afraid of damaging if I try to remove them needlessly.

 

I'm hoping someone out there has solved a similar problem or has some thoughts on how I should proceed before spending more money replacing things that don't need replaced.
 
1 - 1 of 1 Posts
Top