AVS Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
328 Posts
Discussion Starter #1
Hello,

When winter came my receiver started emitting all sorts of squealing, pops, and etc...

Now that it has been warming up outside, and the humidly has gone up, this has started to go away. The house stays between 64 and 68 degrees, so it's not like the inside temp is wild.. It just appears to have started when winter arrived, and it possibly going away with spring starting to appear.

Coincidence, or do you think climate cause it to behave crazy?

 

·
Registered
Joined
·
1,160 Posts
Hello,

When winter came my receiver started emitting all sorts of squealing, pops, and etc...

Now that it has been warming up outside, and the humidly has gone up, this has started to go away. The house stays between 64 and 68 degrees, so it's not like the inside temp is wild.. It just appears to have started when winter arrived, and it possibly going away with spring starting to appear.

Coincidence, or do you think climate cause it to behave crazy?
Next time, tap on the top, grab it by both sides and try to twist the chassis- this seems like it may have bad solder joints or something has failed. Make sure the room is totally dark and look inside when it happens- if you see arcing, that will be the likely location of the problem.
 

·
Registered
Joined
·
328 Posts
Discussion Starter #3
Thanks for the input..

Warmest day of the year so far, and it was flawless... First time for Months...

If it happens again I will check that out.. This unit always has capacitive touch buttons.. I could imagine that those could go a little wild.
 
1 - 3 of 3 Posts
Top