AVS Forum banner

321 - 340 of 358 Posts

·
Registered
Joined
·
2 Posts
Question for Pioneer Elite 501 owners. I have owned this receiver for about 9 months now. I am very happy with it. I upgraded from a Onkyo 717. The speakers I used on that receiver I carried over to the Elite receiver. I have Polk CS1 for center channel and 2 Polk monitor 60’s for front stage. It sounds very good, but I feel since I upgraded to a Much better receiver I could be under powering it. Any suggestions on what front stage (center channel, left and right speakers) would send this receiver over the top in sound?
 

·
Registered
Joined
·
13 Posts
The receiver that keeps on giving! Grief that is!

I have several analog tape machines going into the 501 receiver, which work fine. I just got a new reel 2 reel machine. Went to plug it into the receiver's audio-in #2 CBL/SAT RCA jacks. Both L/R channels are dead! I checked cables, swapped cables, no problems, only problem is this "ELITE", I won't finish the sentence :mad:
 

·
Registered
Joined
·
135 Posts
Last couple pages of this thread have me worried. I'm buying something from A4L and they are recommending the Elite SC-LX501. It does suit my needs but I would like to get a reliable receiver.

Any happy customers (who bought from A4L)?

My concern is that they are getting refurbs that are just plagued with issues.
 

·
Registered
Joined
·
13 Posts
Last couple pages of this thread have me worried. I'm buying something from A4L and they are recommending the Elite SC-LX501. It does suit my needs but I would like to get a reliable receiver.

Any happy customers (who bought from A4L)?

My concern is that they are getting refurbs that are just plagued with issues.

My receiver was factory new from an authorized seller! It's been plagued with problems since day one. It's either not compatible with some of my electronics, tried to destroy my PC. I've never been able to use all of it's features going directly through the 501. I ended up going back to using the optical cable out from the TV hub for audio only. The thing is, just before getting the 501, I had my PC, BD player going into the Samsung MU8000 65", HDMI HUB! Just months before, I had to replace my Pioneer Elite receiver that lasted for a wonderful 16 years! Everything was compatible with the new TV through it's hub, not the new receiver!
 

·
Registered
Joined
·
194 Posts
Discussion Starter · #325 ·
Last couple pages of this thread have me worried. I'm buying something from A4L and they are recommending the Elite SC-LX501. It does suit my needs but I would like to get a reliable receiver.

Any happy customers (who bought from A4L)?

My concern is that they are getting refurbs that are just plagued with issues.
I can't speak for A4L as I bought mine from Best Buy but mine has been rock solid. I originally bought it for use in the basement but as these projects go it stalled and I moved it upstairs to replace a Pioneer 1020. It works better in every way than the 1020 except that the amber display is ugly and doesn't match the blue LED of the power button. Its runs everyday for hours and, knock on wood, it just works. I run a TiVo Bolt, Apple TV 4K and Xbox One S through it and have a single HDMI running up to the Vizio M series display.
 

·
Registered
Joined
·
135 Posts
Thank you for both of your responses. I ended up buying the Pioneer from Accessories4Less and it seems to work well. I have it running a 5.1 home theater setup with a single HDMI out going to my Epson projector. All of my equipment is in another room so I don't see the lights on the front.

Inputs are cable box, DVD player, Chromecast, PS4, security camera DVR and amazon fire stick.

I also like the 2nd out (sub out) as I have a 2nd monitor mounted in my equipment closet so I can see the displayed image and the receiver at the same time.

Maybe I haven't found it yet but I wish there was a quick way to switch between movie, TV and music sound settings. Probably is and I'll figure it out as I continue to learn this machine.

Fingers crossed that things continue working well.
 

·
Registered
Joined
·
135 Posts
Is anyone able to pair the bluetooth to their phone? I do not see it in the available devices when I scan. I have it all turned on through the settings menu.

Am I not understanding it correctly?
 

·
Registered
Joined
·
3 Posts
Hi, when I try to listen to music from files on a usb memory stick the player only sounds if there is a TV connected, also when I press the USB button on the remote control it automatically changes the HDMI channel of the TV. It seems that this is so in this player because in the advanced manual says that the first thing to do in the case of playback from USB is to connect the TV to the receiver's input. Is this true of all receivers too? It seems strange at least.
 

·
Registered
Joined
·
2 Posts
Help, Pioneer Elite sc-lx501 receiver

I'm trying to setup my pioneer elite sc-lx501 receiver so that the zone 2 HDMI output always matches the main zone. I have a couple of kids and its tough for them to figure it out. I have a projector screen as the main and a TV on the side that pulls out from the wall for basic TV stuff. Is it possible for zone 2 to mirror the main zone all the time?

Thanks
 

·
Registered
Joined
·
2 Posts
I'm trying to setup my pioneer elite sc-lx501 receiver so that the zone 2 HDMI output always matches the main zone. I have a couple of kids and its tough for them to figure it out. I have a projector screen as the main and a TV on the side that pulls out from the wall for basic TV stuff. Is it possible for zone 2 to mirror the main zone all the time?

Thanks
ss
 

·
Registered
Joined
·
1 Posts
On my previous Denon receiver I could have mismatched audio and video inputs playing at the same time (I.e. Bluetooth audio and cable/sat video). I see this 501 doesn’t have that. Has anyone found a workaround?

Thanks!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
75 Posts
Amazon Fire Stick 4K (new)
Pioneer SC-LX501 AVR
LG Oled C6 TV
Fire Stick into AVR HDMI in. AVR to C6 TV by HDMI. Dolby Vision does not pass-through the AVR to the TV. All devices are Dolby Vision compliant. I do get HDR but not Dolby Vision. Does anyone have any ideas?
 

·
Registered
Joined
·
13 Posts
I got this on my LX501 face display(not on screen) message "Video assert 2!". Anyone seen this before, or know what it means? I just finished watching a tv show, and did nothing to the receiver. I hit the mute button on the remote control, and it disappeared. Strange.
 

·
Registered
Joined
·
1 Posts
2.1 setup problem

I have a pair of klipsch tower rp-280fa and a klipsch Sup. Trying to run speakers large but when I do it cuts my subwoofer off. Should I not run the towers at large? I have sub on and crossover set at 80hz from receiver.
 

·
Registered
Joined
·
10 Posts
Is there anyone who has/was same problem like mine?? :(


1) - After a setup from factory state the ChromeCast Audio device is visible on my network and I'm able to use it from my iPhone (Tidal), but after a while that is disappearing. This symptom is existing on my system with the latest few firmware versions too (I just hoped to they fix it, but didn't happen till now...)
(I tried on LAN and WiFi connection too, with two different WiFi routers)

2) - I really need the DIMM (dimmer) button from the remote and I plan to purchase a Logitech Harmony and I'm just curious may I set somehow this function programming?

Thanks in advance!
 

·
Registered
Joined
·
19 Posts
Is there anyone who has/was same problem like mine?? :(


1) - After a setup from factory state the ChromeCast Audio device is visible on my network and I'm able to use it from my iPhone (Tidal), but after a while that is disappearing. This symptom is existing on my system with the latest few firmware versions too (I just hoped to they fix it, but didn't happen till now...)
(I tried on LAN and WiFi connection too, with two different WiFi routers)

2) - I really need the DIMM (dimmer) button from the remote and I plan to purchase a Logitech Harmony and I'm just curious may I set somehow this function programming?

Thanks in advance!
1. I had the same problem on wired network but it stays up on WIFI so there must be something wrong with the wired network on my reciever. Some routers and APs will let you disable IGMP snooping which can cause devices to disappear. My setup is Asus AC68U as wired router with multiple Unify APs and I have IGMP disabled.
2. I posted earlier in this thread how to use Dimming by setting up an older model on the Harmony Hub.
 

·
Registered
Joined
·
10 Posts
Many Thanks for your reply!

1) So the solution is the adding SC-91 codes ;)

2) So I have to switch the AVR to WiFi from LAN and I have to disable the "IGMP"?
(My router is Asus AC-86U) Do you know where can I find this in the settings? (I tried, but I didn't find it...)
The AC68U (yours) very similar to AC86U (mine)

Thanks!
 

·
Registered
Joined
·
19 Posts
Many Thanks for your reply!

1) So the solution is the adding SC-91 codes ;)

2) So I have to switch the AVR to WiFi from LAN and I have to disable the "IGMP"?
(My router is Asus AC-86U) Do you know where can I find this in the settings? (I tried, but I didn't find it...)
The AC68U (yours) very similar to AC86U (mine)

Thanks!
The setting is on my the controller for the APs but upon checking it does not do anything unless you also have an Ubiquity router which I dont have, I don't think I have seen it on the Asus router. On my AC68U I use Merlin's firmware, this might be a thing to try as well.

More reading...my setup might work because I am not using the wireless on the router and my receiver is also not on the wired port.
https://www.snbforums.com/threads/r...ent-multicast-forwarding-igmp-snooping.47201/
 

·
Registered
Joined
·
10 Posts
The setting is on my the controller for the APs but upon checking it does not do anything unless you also have an Ubiquity router which I dont have, I don't think I have seen it on the Asus router. On my AC68U I use Merlin's firmware, this might be a thing to try as well.

I'm using the latest Merlin FW too on my AC86U - So I don't know how can I fix this...as far as I remember the problem was there on WiFi connection too... :confused:
 

·
Registered
Joined
·
5 Posts
Can anyone tell me if it is possible to play a movie in 7.1.2 dolby atmos with this receiver? I tried many ways, but i can't figure how. In the speakers set-up, i chose 7.1.2, but when i watch a movie in 7.1 dolby atmos, on the remote i have to press (av adjust), and then in (other), than chose speakers, i have to choose between surruond or height. If i choose height, it tells me i' in 5.1.2, if i choose surround, it tells me i' in 7.1.

So, anybody have suggestions? :(
 
321 - 340 of 358 Posts
Top