AVS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Has anyone else experienced this? The grip belt itself has snapped at the front mounting point - the webbing has just snapped. I've had the camera a year and it has had heavy use.


Any ideas how to fix? Looks like a trip to to the repair shop.


I noticed there are 4 or 5 tiny cross headed screws that if removed may allow the covering plastic plate on the right hand side to be lifted off to give access to the grip belt mounting, but I can't find a service manual to guide on disassemby. Anyone got a link please?


Cheers


Ian
 

·
Registered
Joined
·
264 Posts

Quote:
Originally Posted by Imaddison /forum/post/0


Has anyone else experienced this? The grip belt itself has snapped at the front mounting point - the webbing has just snapped. I've had the camera a year and it has had heavy use.


Any ideas how to fix? Looks like a trip to to the repair shop.


I noticed there are 4 or 5 tiny cross headed screws that if removed may allow the covering plastic plate on the right hand side to be lifted off to give access to the grip belt mounting, but I can't find a service manual to guide on disassemby. Anyone got a link please?


Cheers


Ian

My best advice to you is to call your Panasonic service center to have it replaced (probably at your cost since this is usually not covered by warranty, being considered abusive use). Dismanteling the camcorder yourself is a risky business, as these things can be hard to put back together sometimes (even with the steps on how to do it), and you would still have to order a replacement strap from them anyway. Service manuals for such a recent model could be also hard to find (unless ordered from Panasonic, again at your cost).


Good luck.
 
1 - 4 of 4 Posts
Top