AVS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Yea, I realize this is a very old, 10 year old, projector, but it is still ticking. I've searched the Toshiba support sites, AVS forums, and InFocus support and am unable to find MT8 firmware to update from the original v2.5. In other threads here on AVS, there is discussion of a Toshiba-branded InFocus v3.5 firmware that is available that enhances the old girl. Unfortunately, Toshiba support doesn't even return search results for the MT8 and the v4.0 FW from InFocus won't load because of a mismatch with device ID and the driver checking.


So, I'm hoping someone here still has the Tosh v3.5 floating around. Or, maybe a IF version pre-device ID checking that I could flash, then flash to v4.0.


Thank you in advance for any help.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
In addition to the above post, I sent several PMs to individuals that had participated in discussions of the SP720 / MT8 and who currently post on this board. One of them, Barry, was very helpful and forwarded me a v3.9 of the InFocus firmware for the SP7200. It flashed just fine. I was then able to flash the v4.0 fw. So far, so good. all that *should* be working is. Except HDCP...


But, the common "HDCP board not implemented properly" problem got me.


Does anyone have a borked later model SP7200 I could buy that had the HDCP board swap that I could use to swap out my HDCP board?


TIA.. Thanks for your help, Barry.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
HiFiChris1234...


Nope, never found the HDCP board, didn't hear from anyone having one for sale, haven't found what I feel would be a decently priced unit on eBay. But, the pj is still chugging along after the pw supply board repair. It's working great connected to my PC @ 720p. I'm just biding my time now for a pj upgrade, taking my time looking at the newer models.


If you do find a solution, please drop a line in this thread and I'll catch it.
 

·
Registered
Joined
·
4 Posts
Wisiwyg,


If I find out anything I will let you know.


Did you get the firmware resolved? I was able to update mine from Toshiba 2.5 to InFocus 4.0 without any problems.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Yep, SW updated just fine. PJ is working great, aside from the inability to run HDCP content. I'll probably end up using it at work for business presentations once I find and can afford a good replacement.
 

·
Registered
Joined
·
4 Posts
Wisiwyg,


I ended up buying a 7210 off of ebay for only $125. Hooked it up to HDMI with M1-DA adapter and it's working great.


I will upgrade to a 1080p projector somewhere down the road, though.
 
1 - 7 of 7 Posts
Top