AVS Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I currently have a Triple LNB DirecTV oval dish with four lines going to four receivers. Dish is set up for HDTV and I will be adding a receiver in the near future. I bought a Terk 5X8 cascadable multiswitch so I could hook up 8 receivers. I am hooking up wrong or the new multiswitch is bad. I get no reception on any of the outputs. Does it matter which of the four input lines goes to what input? The inputs are labeled SAT A 13V, SAT A 18V, SAT B 13V, and SAT B 18V. I didn't think it mattered which line goes to which input on the multiswitch since there is already a multiswitch built into the dish. If it does matter is there an easy way tell which line is which, since they are buried underground? The power is hooked up to the multiswitch. Any help would be appreciated
 

·
Premium Member
Joined
·
7,093 Posts
Since all 4 receivers were working, the dish, it's built in multiswitch, and your cables are ok. It doesn't matter which lines go to which input on the new multiswitch since they all are functionally identical. It sure looks like the new multiswitch is not working.
 

·
Registered
Joined
·
24 Posts
You need to make sure that that switch is compatible with the 18*20 inch phase three dish. * assuming you have a phase III dish.


Jvi makes a multiswitch that is compatible with the new dish, i am not sure about your switch though.


David
 

·
Registered
Joined
·
1,390 Posts
The Terk M58 is compatible with the Phase III dish.


Have you confirmed that you actually have power by checking the end of the cable carrying power at the Multiswitch with a voltmeter? Did you make the cables yourself? Maybe there's a short or break in that cable?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Thanks for the replies. The cables are all good. I will check the power at the multiswitch with a voltmeter but it looks like a bad multiswitch. You begin to doubt yourself when you get a bad product out of the box.
 

·
Registered
Joined
·
209 Posts
I too have a multiswitch problem, however, I get good signal on Sat C but nothing on A or B. I called Terk and they are supposedly sending out a new multiswitch. I hope that is the problem.
 

·
Registered
Joined
·
655 Posts
Check for grounding out and shorts.

We have seen this many times on the 5x8 switches.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top