AVS Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi

As the topic describes I'm having trouble with 24 Hz video playback.

First of all some information about my setup:

Software: Windows 7 (x64) with Media Player Classic Home Cinema (v.1.3.2353.0 x64) and ffdshow (rev. 3546).

Hardware: E8400 (@3.6GHz), ATI HD5770, 4GB of RAM

AV setup: BenQ W5000, Onkyo TX-NR807 (connected with: Optical SPDIF)


When I play video files (23,976 fps) with the display refreshrate set at 50 Hz the playback is fine, except from the jerky pans caused by the 50 Hz refresh rate.


The problem occurs when I'm setting the screen refreshrate to 23,976 Hz (which is displayed as 23 Hz in Windows, I also know my projector is accepting this). When I play movies at this setting the video is getting all stuttered/choppy. I have checked CPU-, GPU- and RAM-usage. All is fairly low, so I know this isn't the problem.

Sometimes the playback might work fine for 10-15 minutes, until the extreme stuttering starts.


I believe the problem is caused by audio/video sync. It seems like the video is being sped up like every 2 seconds or frames are being dropped to keep sync with the audio bit-stream. I'm not sure if this is really the case, nor how to fix it.


So I'm hoping for input from you guys on where to start. Everything will help. I'm open for trying different software than what I'm currently using.


Edit: I should add that the video playback at 24 Hz works flawlessly if i ditch the DTS/DD sound and use 2 ch.
 

·
Registered
Joined
·
81 Posts
Quote:
Originally Posted by chlo
Hi

As the topic describes I'm having trouble with 24 Hz video playback.

First of all some information about my setup:

Software: Windows 7 (x64) with Media Player Classic Home Cinema (v.1.3.2353.0 x64) and ffdshow (rev. 3546).

Hardware: E8400 (@3.6GHz), ATI HD5770, 4GB of RAM

AV setup: BenQ W5000, Onkyo TX-NR807 (connected with: Optical SPDIF)


When I play video files (23,976 fps) with the display refreshrate set at 50 Hz the playback is fine, except from the jerky pans caused by the 50 Hz refresh rate.


The problem occurs when I'm setting the screen refreshrate to 23,976 Hz (which is displayed as 23 Hz in Windows, I also know my projector is accepting this). When I play movies at this setting the video is getting all stuttered/choppy. I have checked CPU-, GPU- and RAM-usage. All is fairly low, so I know this isn't the problem.

Sometimes the playback might work fine for 10-15 minutes, until the extreme stuttering starts.


I believe the problem is caused by audio/video sync. It seems like the video is being sped up like every 2 seconds or frames are being dropped to keep sync with the audio bit-stream. I'm not sure if this is really the case, nor how to fix it.


So I'm hoping for input from you guys on where to start. Everything will help. I'm open for trying different software than what I'm currently using.


Edit: I should add that the video playback at 24 Hz works flawlessly if i ditch the DTS/DD sound and use 2 ch.
Look here
http://www.avsforum.com/avs-vb/showthread.php?t=1291323
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Thanks for your response.

I can't see how that thread relates to my problem? I'm currently using an optical SPDIF for digital audio from my HTPC for my receiver, so I'm not having trouble with the HD surround tracks. (The SPDIF is connected to the PC motherboard)


I get DTS/DD tracks, and video playback works fine in 50 Hz. 24 Hz video is smooth with 2 ch. audio. I just can't get 24 Hz video and DTS/DD audio without video stuttering. The audio is always fine, it's just the video which is being affected by the stuttering.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
24 Hz (23 Hz in Windows) is definitely the best setting for my setup in terms of smoothness.


Does anyone know if it is a known problem with video speedups (and framedrops) with 23.975 fps and audio bit-stream? Is there any settings in MPCHC or ffdshow which would effect this?
 

·
Registered
Joined
·
1,035 Posts
I had the same problem. This is how I have it set up now.


DVD > FFdshow + Avisynth

MKV > MPC (DXVA)


EVR Custom Pres.

All three Vsync turned on

Aero disabled
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
I already had MPC set to EVR Custom Pres. output.

I couldn't find the three Vsync's you were talking about. Is it the ones in EVR Sync Settings?


Are you running any External Filters?
 

·
Registered
Joined
·
1,035 Posts
Give a right mouse click on the screen. Vsync and Aero will be hiding in Renderer Settings.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
Thanks for all help so far

Haven't tested much yet, but your setting seems to work
I have struggled with this for a wile now, so it's really nice to finally have it work.


Do you know if there is any way that MPC can automatically adjust the screen refreshrate based on the movie fps? (Automatically switch between 23.976, 24.0, 25, etc fps)


Are you guys using any kind of postprocessing, shaders etc for MKV?
 

·
Registered
Joined
·
1,035 Posts
View>Options>Fullscreen....check "Use autochange"


choose monitor refreshrates from the dropdown lists
 
1 - 13 of 13 Posts
Top