AVS Forum banner
  • Our native mobile app has a new name: Fora Communities. Learn more.

Unable to program Harmony 670-Unable to display content

1732 Views 0 Replies 1 Participant Last post by  markwco
I just purchased a Harmony 670 remote and have had trouble programming it. For some reason when I try to I get to a screen where I enter my login information and then I get a screen that says "Unable to display content" "Click Next to Continue" and when I click Next it takes me back to the login screen.

I am using the newest version of the software I just downloaded from Logitech's website and am using it on a Mac with OS X. I tried it on another Mac and even a Windows XP machine with the same results.

I even though maybe the Harmony 670 I just got isn't working so I tried it with a Harmony 688 remote I have from a few years ago and it also did the same thing. I can tell that my computer is seeing the remote when it's plugged in. This is an account I set up to program other Harmony Remotes I have. I did some research on Google and was unable to find an exact cause or solution so any ideas what could help me?

Thank you for your help.
1 - 1 of 1 Posts
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.