AVS Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I recently installed Mythbuntu7.1 on a Biostar TF7050-M2 mobo. I had to install in Safe Mode because it could not detect my graphics card. Since then, I have been unsuccessful in updating my graphics drivers.


Can someone point me to a graphics driver that will work with my setup.


Thanks in advance
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
NVIDIA listed the Linux driver as not available. I also tried the NVIDIA driver in the restricted list, but had bad results. I know there are many people using this board with Linux, but I just have not been able to find a driver that works.


Let me know if you have better luck.
 

·
Registered
Joined
·
8,770 Posts
Try using the Envy video driver installer utility- I haven't tried it on my Biostar TF7050 board yet, but the installer appears to work great on another recent build I did with an FX5200 card.


It grabs the most recent driver and related files and builds it up from scratch using its own routines and scripts.


Just downlaod and execute the *.deb "Envy New" at

http://albertomilone.com/nvidia_scripts1.html


Direct Link
http://albertomilone.com/ubuntu/nvid...buntu1_all.deb


A stopgap solution is to simply buy a PCIe card that is supported well with current Nvidia drivers and installers. When your 7050 issue is resolved, just sell the card or use it for another machine or build, or upgrade your Mom's PC



Here is a $29.99 shipped PCIe 6200 card with DVI, Svideo and VGA and 256MB:
http://3btech.net/jenvge6225dd.html


EDIT: according to the Nvidia site and links below, the 7050 should be supported fine with the December 2007 driver 169.09
 

·
Registered
Joined
·
8,770 Posts

Quote:
Originally Posted by wnewell /forum/post/12878143


Just bought a 7050 board. haven't installed it yet. Did you try the official driver from nvidia.com?

Agreed.


Try

http://www.nvidia.com/object/linux_d...32_169.07.html


and follow instructions there.


According to
http://us.download.nvidia.com/XFree8...ppendix-a.html


and

http://www.nvidia.com/object/IO_18897.html


the Biostar TF7050 should be supported as:


GeForce 7050 PV / NVIDIA nForce 630a 0x053B

GeForce 7050 PV / NVIDIA nForce 630a 0x053A


using this driver

http://www.nvidia.com/object/linux_d...32_169.07.html


Try the Nvidia procedure first, then the Envy installer I mentioned and linked above.
 

·
Registered
Joined
·
8,770 Posts
I developed and tested a procedure here:

http://www.avsforum.com/avs-vb/showthread.php?t=983686


It works for Mint 4.0, and should work for all Ubuntu flavors, including Mythbuntu 7.10, but I only tried Mint.


You might want to reinstall Mythbuntu 7.10 from scratch. Before configuring Myth, do the procedure in the link.


If that doesn't work, use Mint 4.0 or Ubuntu 7.10, do the procedure, then install Myth from Synaptic.
 

·
Registered
Joined
·
566 Posts

Quote:
Originally Posted by cyberizzy /forum/post/12875975


I recently installed Mythbuntu7.1 on a Biostar TF7050-M2 mobo. I had to install in Safe Mode because it could not detect my graphics card. Since then, I have been unsuccessful in updating my graphics drivers.


Can someone point me to a graphics driver that will work with my setup.


Thanks in advance

Finally got around to installing my ECS 7050M-M board. Mythdora 4.0 and Knoppmyth R5F27 wouldn't work. Installed Mandriva 2008 and got myth working but the video just didn't work quite right. I could have probably fixed that, but I couldn't get the sound working right. Mythdora didn't have a problem with the sound, but couldn't get a display after loading and rebooting. I should point out that was using VGA, and the TV I have won't take standard 1280x720 on the vga port. Works fine in the HDMI port, but this cheap board is VGA only. I'd highly recommend a board with dvi or hdmi out to avoid this type of problem.

Finally gave up on the 3 distros I had and downloaded Mythbuntu 7.10. Thought I was going to have problems with it too since during the install the screen was a little flakey, but once it loaded the Nvidia driver everything worked great. When it booted with it, it came up in 1360x768 mode without a problem. It's also a hell of lot easier to setup a slave server with it. The one thing lacking was the firmware file for my old HDTV card, but that's nothing. There are a couple of things I don't like about it though. I can't get into root with it, but anyway, that's for another day. Bottom line is it worked, and fairly easy when the others wouldn't. Just hate to start on lirc for my serial ir receiver without root access. I hate sudo.:)
 

·
Registered
Joined
·
196 Posts
You could always use "sudo su" to get a root access terminal.


You can use sudo to change the root password, too, so you can use it.
 

·
Registered
Joined
·
566 Posts

Quote:
Originally Posted by FreeFire /forum/post/12957952


You could always use "sudo su" to get a root access terminal.


You can use sudo to change the root password, too, so you can use it.

Yep, I can do sudo xterm, or sudo thunar for a file manager, but that doesn't help me when I try an ssh in as root.

Can you be more specific on how to change the root password using sudo? sudo chgpassword didn't work for me. It appeared to take root
assword, but it didn't give me access.. Not really a point now that I have most things working.
 

·
Registered
Joined
·
196 Posts
Ubuntu doesn't come with a root password. To add one, "sudo passwd root" should work. Also, you could log in as root and then do "passwd" to get a root password. Here's a couple of links for examples and more information:

http://www.debuntu.org/2006/04/24/34...r-the-sudo-way

http://www.debianadmin.com/enable-an...-password.html


I haven't tried this accross an ssh link, but I don't see any reason it shouldn't work. In fact, I've gotten used to using sudo so I don't worry about my root password on my Ubuntu system.
 

·
Registered
Joined
·
1,591 Posts
I wrote this in the other thread, but you are better off using
Code:
Code:
sudo -i
or
Code:
Code:
sudo -s
than enabling the root account. This will give you a root shell that you can execute root commands without sudo and without enabling the root password, and will work after you've ssh'd in too.
 

·
Registered
Joined
·
566 Posts
sudo passwd got it going. Thanks a lot. And it also works with ssh. Makes life much simpler. Now I can sit in my easy chair and configure it.:)
 

·
Registered
Joined
·
566 Posts

Quote:
Originally Posted by newlinux /forum/post/12980444


I wrote this in the other thread, but you are better off using

, and will work after you've ssh'd in too.

The problem with that way is I usually use gftp for ssh sessions where I have to move/edit a lot of files, and that method won't work like that I don't think.
 

·
Registered
Joined
·
1,591 Posts

Quote:
Originally Posted by wnewell /forum/post/12981954


The problem with that way is I usually use gftp for ssh sessions where I have to move/edit a lot of files, and that method won't work like that I don't think.

Okay. Yeah if you want ssh in as root instead of gaining root privileges after ssh'ng in I don't see any other option other than to enable to root account's password.
 
1 - 14 of 14 Posts
Top