AVS Forum banner
  • Our native mobile app has a new name: Fora Communities. Learn more.

Updating Firmware on Viewsonic VMP72

6218 Views 4 Replies 3 Participants Last post by  MrLarkin
Hi All, Hopefully someone will find this useful

After updating firmware on Viewsonic VMP72 HD network media player Model VS13057 - it wouldnt work. (Firmware obtained from Viewsoniceurope site for this model) (tried it 4 times with new downloads & on different usb sticks)(would only get viewsonic logo). (No firmware update on the Australian site for the same model, but user manual has a better networking interface than what is on player)

After reading here about clones I did some reasearch about people using firmware from other providers on products that "look" the same. (The risk being the insides may have extras etc)

So I tried the cinematube firmware from brite-view as I had nothing to lose (my viewsonic was a day old) and even though it states the firmware is only for the Americas NTSC (not PAL where I am)

Firmware Version: IPB10106251 (US01) for Cinema Tube

Anyway, I had a WIN & I can use myViewsonic VMP72 again with added extras.

It did the same upgrade process with the image on the usb & it went flawlessly, & funny enough the viewsonic logo still appears as the splash but the contents are different.

Cheers from the Outback

See less See more
1 - 5 of 5 Posts

Thanks for your post. I wanted to try the same, but I read somewhere that the remote control ceased functioning. I was also a little concerned because I don't have a copy of the original fw in case the Brite-view doesn't completely work.

So, is everything working for you? Did you update through the on screen menu or did you hold down the power button when powering up the VMP72?

Appreciate the info. Thanks!

See less See more
Well, I couldn't wait. Tried installing the Fw through the menu, but that didn't work. Used the bootstrap method and Bingo! Thanks again Garrynt. I also discovered firmware for the Zinwell 5005HD which is supposed to have even more features than Brite-view. Here's the link:
zintv.tv/support (can't show full link)

Haven't tried it yet because nobody else seems to have and I guess I'm a chicken at heart. (Insert chicken sounds here)

I bought the VMP72 recently and upgrade with the europe firmware and it also have the same problem as garrynt faced. It stopped at logo screen without any further action.

I then upgrade with Zinwell 5005HD as recommended by MrLarkin and it works. It has feature like yahoo finance, yahoo weather, flickr, picassa and mediafly which is similar to youtube.

But I would prefer youtube. Do anyone know is there any firmware that has Youtube feature?


See less See more
Well done Warren. As far as I know there isn't anything for YouTube right now. There used to be, but apparently YouTube changed their protocol and since then none of the Brite-View, Zin5005, or VMP72 firmware have addressed this problem.

I haven't purchased a wireless usb for the unit yet, so I haven't upgraded to Zin5005hd fw yet.
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.