AVS Forum banner

161 - 180 of 350 Posts

·
Registered
Joined
·
808 Posts
My MX-990 has just started to do something odd. When I put it back in the cradle it is rebooting itself instead of just starting the charge.

Has anyone else seen this?
 

·
Registered
Joined
·
2,755 Posts
My MX-990 has just started to do something odd. When I put it back in the cradle it is rebooting itself instead of just starting the charge.

Has anyone else seen this?
I've seen that once - could be a very low battery level?
 

·
Registered
Joined
·
808 Posts
I've seen that once - could be a very low battery level?
My battery never really gets low since it is always in the cradle when I am not using it.
 

·
Registered
Joined
·
808 Posts
Interesting - have you tried reloading the program?
I am on with URC tech support now. Let’s see what they say. Reloading the software is definitely an option.
 

·
Registered
Joined
·
808 Posts
The only thing they could come up with is the battery so I will replace it. Now I have to find one that fits.
 

·
Registered
Joined
·
808 Posts
Found this:

Amazon

Also you might want to check with Surf Remote:

http://www.surfremotecontrol.com
Thanks.

When I asked tech support if the MX-990 battery was the same as the MX-980 they told me no. I was transferred to the parts department and they told me that the batteries are the same so I ordered the one you found on Amazon.

I will report back once I get the battery.
 

·
Registered
Joined
·
808 Posts
I am getting close to the point of getting rid of my MX-990 and going with the different manufacturer. I like the remote but most of the time I cannot get my computer to recognize it. I have been trying for an hour now but it doesn't show up in device manager and complete control doesn't see it.
 

·
Registered
Joined
·
2,755 Posts
Sounds like a bad unit - are you out of warranty? When I occasionally get the device not recognized, I remove the battery for several seconds (at least 15), force a reboot and then it's recognized. I do not connect through the charger but with a USB cable. I only use the charger for charging.
 

·
Registered
Joined
·
808 Posts
I have had this unit for 1.5 years and have glitches in connecting since day 1. I had similar issues with my MX-980. The MS mobile device connection process is really bad. With the Sept 2017 Windows 10 update they disabled portions of it.

Right now I can run the WMDC but I can't connect my 990.
 

·
Registered
Joined
·
2,755 Posts
I connect using a USB cable from the remote directly to a motherboard-supported USB input. If I open Windows Settings / "Bluetooth and other devices", it shows up under "Other devices" as URCHID.
 

·
Registered
Joined
·
808 Posts
Thanks for all your help.

Let me see where mine shows up.

Where did "URCHID" come from? Is that what you named the remote?
 

·
Registered
Joined
·
2,755 Posts
Thanks for all your help.

Let me see where mine shows up.

Where did "URCHID" come from? Is that what you named the remote?
No, it must come from the device's base programming.
 

·
Registered
Joined
·
2,755 Posts
Which windows driver are you using?
Just the default MS device. I'm on Windows 10 PRO x64 version 1709 build 16299.192, up-to-date.
 

·
Registered
Joined
·
808 Posts
Maybe my remote is messed up. It shows up in the device manager in a weird place and even if I assign it a driver it never shows up in the windows mobile device center.
 

·
Registered
Joined
·
2,755 Posts
I never use the Mobile Device Center. In fact I avoid anything with Mobile in its name :)

What is the weird place it shows up in?
 

·
Registered
Joined
·
808 Posts
I never use the Mobile Device Center. In fact I avoid anything with Mobile in its name :)

What is the weird place it shows up in?
Other devices / network controller
 
161 - 180 of 350 Posts
Top