AVS Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello All, I have a 10 year old Velodyne VA-8100X that started sounding bad this weekend. Watching a movie & all of a sudden the sub sounded horrible,

distorted etc. I removed the 8" driver and it looks like the foam surround is no longer attached to the frame. Not sure if this makes it sound bad or not.Maybe something internal is also bad?

I like the sound of this unit (when it was working) and it has served me well and don't have the bucks to buy a new unit.

Is there a source for replacement speakers? I checked the web and although there are some 8" woofers out there I'm not sure which to buy. I left a message at Velodyne parts this am but have not received a call back yet.

Any advice would be much appreciated!
 

· Registered
Joined
·
2,043 Posts
you could put any 8" driver in there that fits and has the same impedance, but it may or may not sound better than it originally did. every sub is designed to work with a specific driver. i'd wait for a reply from them and see if they have a replacement available for it.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Thanks for the reply...they did call back. There are none left in stock. They directed me to a site called speakersaver.com. I called there and they said it would be about $35 to install a new suround. Obviously there would be the cost of shipping back and forth. Any one have experience with this company. Will the speaker sound as good etc???
 

· Registered
Joined
·
2,043 Posts
maybe it's just time to upgrade the entire subwoofer to something new.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top