AVS Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Greetings all: I have a Vidikron VPF40SE I acquired in '02. It has performed flawlessly until two days ago. Now, after running normally for approximately 5 minutes, the picture will become unstable and finally collapsing to a horizontal line at which point the projector goes into "protect" mode which shuts down the high voltage. While in this mode, there is a "V. Ramp" alarm LED lit on the larger of the two boards mounted on the top of the chassis which is presumably the deflection board. Cycling the master power switch will restore operation until the failure repeats itself. I am seeking any technical documentation or assistance on this projector if it is available. Web searches thus far have turned up very little info on this model.


Thank you.

Carl Campbell

Old Hickory, TN
 

·
Registered
Joined
·
18,506 Posts
I've got V boards at $60 incl shipping within the US. At that price, it's not worth repairing the old one.


SHoot me a PM or email me at [email protected]


Thanks!


Oops! Email me a pix of your set before I commit to the above. You might have the older Vidikron made sets, which you're right, there's no info out there for them. Vidikron is out of business long ago, and the Runco owned 'version' of Vidikron knows nothing about those sets. I hate to say it, but the Vidikron made sets weren't very reliable, although back in the day they showed a good image. I've thrown about 5 of them out in the last 2 years as nobody wanted them.


If the set is the Electrohome based chassis that they got into, then I've got the board you need.
 
1 - 2 of 2 Posts
Top