AVS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello all, have been a lurker of AVS since the early days and appreciate the great content here. I hope this is posted in the right area.

After grabbing this Sony HS51 at a flea market, throwing in a new bulb, I am seeing the following blob on the projection output. The crackling effect I am seeing is focus-able.

Thanks in advance for any guidance. I am technical and have the device disassembled currently.

 

·
Registered
Joined
·
7,182 Posts
Dead projector, get a new one.

Most likely the LCD panels are cracked, or burnt up. This can happen with age, or due to use of a non-factory original lamp in the projector most often. The non-Sony lamps aren't always properly treated to prevent UV rays and they burn the panels.

I haven't heard of people just repairing this on their own, or very rarely. Parts and pieces tend to be very specific, and Sony replacement parts will run several hundred dollars, which isn't worth it on a projector of this vintage.

ALWAYS see a projector in use before purchase. If it has a dead lamp, walk away.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Dead projector, get a new one.

Most likely the LCD panels are cracked, or burnt up. This can happen with age, or due to use of a non-factory original lamp in the projector most often. The non-Sony lamps aren't always properly treated to prevent UV rays and they burn the panels.

I haven't heard of people just repairing this on their own, or very rarely. Parts and pieces tend to be very specific, and Sony replacement parts will run several hundred dollars, which isn't worth it on a projector of this vintage.

ALWAYS see a projector in use before purchase. If it has a dead lamp, walk away.
Thanks so much for the response, truly appreciated. This will find a new home in my trash, luckily only $25.
 
1 - 4 of 4 Posts
Top