AVS Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter · #1 ·
Anybody knows what +15V is for in a NEC XG projectors?


Thnaks,Lei
 

·
Registered
Joined
·
4,018 Posts
The +15volt line is used by many of the +12 and +5volt regulators on the various boards. Why?


Marc
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #3 ·
Marc,


I've got an error "FC" that refers to "+15V off". The PJ powers up and down every 10 sec or so. Do you know Where should I start?


Thanks.
 

·
Registered
Joined
·
4,018 Posts
Try the usual first. Unplug the power connector to the C-drive and F-drive boards. A lot of different boards could pull down the 15volt line.


Marc
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #5 ·
Good suggestion. I have a download PDF service manual, but it's not searchable, therefore hard to use. Could you point me to the C-drive and the F-drive boards? right now, the lid is off, and I lift up the top board assembly also. It seems to me that the PS is underneath the lenses, am I right?
 

·
Registered
Joined
·
4,018 Posts
The PS is under the lenses. The C-drive and F-drive boards are the 2 boards standing up between the tubes. They have the famous STK392-40 chips on them.
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #7 ·
Okay, I can see those thick film integrated STK's. Thanks again.
 

·
Registered
Joined
·
4,018 Posts
That would be my first guess. Unplug them and see what happens.

If the unit fires up, turn it off and plug one back in to eliminate. If it is not caused by either, You may have to check the PS.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top