AVS Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Okay, two months ago my showstopper broke. The input video was choppy and pixalated. After eliminating all of the potential causes it was determined to be a faulty system. I sent it off (with $142) to get it repaired by Panasonic. Two months later (yesterday) I received my fixed showstopper (I made about a dozen calls in the two month period). The "fixed" showstopper was actually a refurbished unit not my original system. After spending a frustrating evening trying to connect to initialize the system it finally had success this afternoon.... here's the kicker. NO VIDEO INPUT!!!!!. After all this waiting I received a broken refurbished unit. None of the inputs work (coax or rca). I've tried all of the forum suggestions. Removing the power cord for a number of minutes... 777zones etc. I've rechecked all of my video inputs and all of them are sending good strong signals. Everything else on the system appears to be working fine, just NO VIDEO.


At this point I'm worn out trying to get a working showstopper. I bought it in December. Used it until April and have been without it since.


Any advice????
 

·
Registered
Joined
·
33 Posts
I'll give you $40 for it, but if it's under warranty you are stuck taking it back for repair. If you live near someone who's isn't under warrenty either you can swap parts until the problem migrates to the other unit, hopefully it's a replacable part, or swapping makes the solution appear.


Good luck. And that's $40 sight unseen!
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
Thanks for the offer. I think if I get to the point that my Showstopper is only worth $40 then I'll just take a sledgehammer to it and relieve some of my frustrations....
 

·
Registered
Joined
·
1,936 Posts
DKQuayle,


Do me a favor. How do you spell that brown, root vegetable from Idaho that is often served baked or in chip form?


I just want to check something.


Thanks,

~Replayer
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
I think that spelling is potato, however, plural would be potatoes. Now you also can use the following spelling if you want to say "The potato's eye is very ugly".


Tomato works pretty much the same way, except they are not typically brown and from Idaho.


If you have any additional spelling questions feel free to send them my way.



DKQ :rolleyes:
 

·
Registered
Joined
·
4,612 Posts
I must have missed your post yesterday.


I don't understand the responses to your post so far. You should be on the phone to Panasonic voicing your displeasure with their service. What if you asked for advance replacement, will they do it? Certainly seems warranted. Hope Panasonic makes good, quickly!
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #7 ·
Thanks for your response. The Showstoppers have a 90 day warrenty so it was no longer covered. My frustration point was due to waiting for two months for a fix and then getting a defective refurbished unit as a fix.


After I sent my initial post (the next morning) I did contact the Panasonic repair facility. Since I had been in contact with them a number of times before I had other phone numbers available to me than just the standard answering machine number.


The Panasonic repair person apologized for the defective unit and promised to send me a "tested" refurbished unit that day. It should arrive today or early next week. Although I'm frustrated at Panasonic I'm grateful to the individual who assisted me in trying to get my system fixed.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top