AVS Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
 http://members.aol.com/tuckerjez//thingy.jpg


the big white thing in the middle, my crossover aint working, all the components are checking out ok except this thing - problem is i dont know what it is or does:( i am told in my local electronics shop that its a cut out of some kind which sounds logical as i am getting almost no signal through the board, i get some but its really quiet indeed. Sadly my local shop doesnt sell them, so i need to know exactly what the beggar is so i can order one or bypass it or something - i dont actually want a cutout anyway as i am very careful with them.


Cheers, might at last get these damn things going!:)
 

·
Registered
Joined
·
1,512 Posts
It's most likely an inductor. Crossover boards are usually a combination of capacitors and inductors. The picture is a bit blurry, tho, so it also might be some type of overload switch, a relay, etc... but most likely it's an inductor.


-Jon
 

·
Registered
Joined
·
77 Posts
Discussion Starter · #3 ·
Cheers for the reply:) here is a slightly less blurry picture, i dont iknow if it will help a lot but it has 5 contact points with the board, my camera is finding it hard to focus this close to the board you see!

http://members.aol.com/tuckerjez//thingy2.jpg


On the side of it, it says:

Quote:
RS Portugal

12v DC

349-131


I dont know what that means though:)
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top