AVS Forum banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
438 Posts
Discussion Starter #1
First of all, I searched the archives, read the FAQ's, even checked Google and couldn't find an answer to this...


I've got two Replays. (5040's when they walked out of the store - 5200's now). I'm running DVArchive as root on my OSX box. I can download from the Replays fine (up to about 1.7 MB/s if I let it go as fast as possible - so I know the wireless connection with my WBR-G54's is fast enough). I can stream back to the Replay's - usually. However, it just seems like I can't stream BACK to the Replay's without the Replay rebooting as the show starts. If the show starts, everything works beautifully.


Now, before someone mentions this, I'll say I know about the issue of the Replay rebooting if you try to play two DVArchive shows in a row. I'm not doing that. I've tried playing immediately after a reboot. I've tried immediately after playing another recorded show - same results.


Now, it's not like I've never gotten this to work before. It seemed to work fine about a month ago. I tried playing a show that was 6 months old, and it crashed (rebooted). So, I figured it was just that show. Nope. There doesn't seem to be any rhyme or reason to me. I had one show that I transferred to DVA that wouldn't play back at all without that problem on either Replay. Now, I've gotten it to play on one Replay, but not the other. Is DVA really this temperamental, or am I doing something wrong?


I've noticed the "getPlayPosition" error a few times, and from time to time if I play the file "Play from beginning", I have a greater percentage of success, but it is by no means a cure.


FWIW, here's my latest errorlog output:


01/21 21:16:45 ERROR: Unable to getPlayPosition for show - no such ID 4009f6ae - as requested by REMOTE ReplayTV @ 10.0.0.203

01/21 21:52:25 ERROR: Error processing served request from DVR Living Room -- Unhandled request: /http_replay_guide-release_show

01/21 21:53:14 ERROR: Unable to getPlayPosition for show - no such ID 400dc0ff - as requested by REMOTE ReplayTV @ 10.0.0.203

01/21 22:02:27 ERROR: Error processing served request from DVR Living Room -- Unhandled request: /http_replay_guide-release_show

01/21 22:24:39 ERROR: Error processing served request from DVR Living Room -- Unhandled request: /http_replay_guide-release_show

01/21 22:27:24 Notice: UPNP:: DVArchive has received a request that ALL DVRs identify themselves - responding

01/21 22:27:30 Notice: UPNP:: DVR at 10.0.0.203 has announced it's going offline - removing it from DVArchive

01/21 22:27:32 Notice: UPNP:: Received UPnP packet from previously unknown DVR @ 10.0.0.203 -- looking up DVR info

01/21 22:27:38 Notice: Timestamp offset for Living Room set to -1 seconds.

01/21 22:28:39 Notice: UPNP:: DVArchive received new DVR broadcast for 10.0.0.203 but wasn't able to initialize/configure it - ignored

01/21 22:28:42 Notice: UPNP:: DVArchive has received a request that ALL DVRs identify themselves - responding

01/21 22:31:04 Notice: UPNP:: DVArchive has received a request that ALL DVRs identify themselves - responding

01/21 22:33:03 ERROR: Error processing served request from DVR Living Room -- Unhandled request: /http_replay_guide-release_show

01/21 22:33:04 ERROR: Error processing served request from DVR Living Room -- Unhandled request: /http_replay_guide-release_show

01/21 22:33:09 ERROR: Error processing served request from DVR Living Room -- Unhandled request: /http_replay_guide-release_show

01/21 22:37:38 Notice: UPNP:: Received UPnP packet from previously unknown DVR @ 10.0.0.203 -- looking up DVR info

01/21 22:37:40 Notice: UPNP:: DVArchive has recognized new DVR ReplayTV named Living Room at 10.0.0.203:80

01/21 22:57:00 ERROR: Error processing served request from DVR Living Room -- Broken pipe

01/21 22:57:00 ERROR: Error processing served request from DVR Living Room -- Broken pipe

01/21 22:57:00 ERROR: Error processing served request from DVR Living Room -- Broken pipe

01/21 22:58:26 Notice: UPNP:: DVArchive has received a request that ALL DVRs identify themselves - responding

01/21 22:58:33 Notice: UPNP:: DVR at 10.0.0.203 has announced it's going offline - removing it from DVArchive

01/21 22:58:33 ERROR: Error reading DVR guide for Living Room -- DVR may have crashed

01/21 22:58:35 Notice: UPNP:: Received UPnP packet from previously unknown DVR @ 10.0.0.203 -- looking up DVR info

01/21 22:58:40 Notice: Timestamp offset for Living Room set to -1 seconds.

01/21 22:59:14 Notice: UPNP:: DVArchive has recognized new DVR ReplayTV named Living Room at 10.0.0.203:80


I'm just stumped. Anyone?
 

·
Registered
Joined
·
3,115 Posts
I am also running DVArchive using OSX. I'm running Jaguar currently. There are some single shows that download to DVArchive that always cause my Replays to reboot. It doesn't matter if I try watching them on my living room or bed room Replay. I have to assume that there is some kind of corruption in the file that the Replay doesn't like. Shows like that (if important enough) I just watch on my TiBook using VLC when I'm on the road.
 

·
Registered
Joined
·
438 Posts
Discussion Starter #3
Well, it's sort of looking like that's what I was afraid of... That's just the way it is eh? Any Linux users have this problem? I know Gerry doesn't have a Mac, so I'm wondering if it's platform specific at all.

Edited because apparently Gary does have a Mac, but doesn't actually write software whereas Gerry is just the opposite. :D
 

·
Registered
Joined
·
8,143 Posts
Quote:
Originally posted by bakerzdosen
I know Gary doesn't have a Mac,
Oh boy... it's Gerry. =)


Any chance you could send the problem show to a PC user, have them d/l it and try to serve it back to the replay?


Does the mac have the same problem with the replay crashing trying to stream two consective shows in a row?
 

·
Registered
Joined
·
3,115 Posts
Yep, Macs have the exact same two show in a row issue.


I'm a multiple OS house--MacOS X, 9.2, 8.6, and 7.6, LINUX, QNX, Win98, and WinXP. The wierd shows that reboot the ReplayTV are screwy whether opened through a PC or a Mac. I kinda have just accepted that about 5% of shows are going to give me grief.


Best,

Matthew.
 

·
Registered
Joined
·
438 Posts
Discussion Starter #6
Oh, see, I'm much higher than that. Like 60% of the shows give me grief. Maybe I just make it a habit of recording weird shows, but it's pretty picky. Now, FWIW, I'm running 10.3.2, not Jaguar. I'm just wondering if it's worth moving up the schedule on the planned Linux/Solaris x86 (haven't decided which yet) box purchase for that reason.


7.6. Wow, that takes me back. :)


I'd try it on my wife's WinME laptop, but there are two problems there: It's WinME, and it doesn't exactly have a wired NIC in it. Just 802.11b.


I'll see if I can find a Win32 machine at work to stream the shows from.
 

·
Registered
Joined
·
1,731 Posts
I doubt there is anything wrong with the shows themselves. I betcha it's a latency issue. For whatever reason, if the network aint top notch a replay will reboot while streaming. All other networking functions will be just peachy.


Those with wireless, try a temporary hardwired connection. I'll bet those 'corrupted shows' play just fine.


In my own (completely wired) experience. I had to replace some self crimped cat5 with factory mades. Like I said, everything works fine, except the streaming.
 

·
Registered
Joined
·
3,115 Posts
Quote:
Originally posted by bakerzdosen
Oh, see, I'm much higher than that. Like 60% of the shows give me grief. Maybe I just make it a habit of recording weird shows, but it's pretty picky. Now, FWIW, I'm running 10.3.2, not Jaguar. I'm just wondering if it's worth moving up the schedule on the planned Linux/Solaris x86 (haven't decided which yet) box purchase for that reason.


7.6. Wow, that takes me back. :)


I'd try it on my wife's WinME laptop, but there are two problems there: It's WinME, and it doesn't exactly have a wired NIC in it. Just 802.11b.


I'll see if I can find a Win32 machine at work to stream the shows from.
I'm running 10.3.2 as well.


--MS
 

·
Registered
Joined
·
438 Posts
Discussion Starter #11
Well, as an update...


Everything's working now - to an extent. Maybe I missed this from a FAQ somewhere, but if I am playing a recorded show and then select a show from DVArchive, it's rebooting. I've played like 10 shows from DVA, and they all work fine --IF-- I am watching live TV first(something that I discovered by accident - I don't usually do that any more :) ). For some reason, it just works while switching from live TV. Recorded stuff? Well, after 5 straight reboots tonight, I think I found the culprit. It doesn't matter if it's coming from the HD or from another Replay.


I may still move the computer or try it from my laptop later, but since I've gotten shows I'd NEVER gotten to stream to stream perfectly, I'm good now.


Anyway, I just thought I'd pass this info on.
 

·
Registered
Joined
·
1,731 Posts
How annoying.


I can tell you what you are seeing is definately not the norm. I never watch live TV and I never give a second thought to viewing something from DVArchive. the only caveat is never play from DVarchive consequtively. Always visit a local show before returing the DVArchive.
 

·
Registered
Joined
·
4 Posts
I just did the recommended DVArchive, then local, then DVArchive

and the result was a ReplayTV crash.


I was running Java 1.4.2 on RedHat 9 (2.4.20-8) on an all-wired

100Mbs network using a Linksys BEFW11S4 v1 (switch). I recently

read that Java 1.4.1 is preferred, so I downgraded. However,

I don't think it's going to make a difference.


My suspicion is that the ReplayTV crash is due to a sloppy a

TCP/IP implementation on the RTV and not Gerry's code nor the

JVM. I'm going to instrument my network and write some test

programs to see what I can find out. I'll post my findings here.


P.S. Gerry, damned good job and thanks for DVArchive.


Jeff


(edit to correct name)
 

·
Registered
Joined
·
1,731 Posts
Quote:
Originally posted by aldebaran
P.S. Gary, damned good job and thanks for DVArchive.

Jeff
BTW, It's Gerry.
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top