AVS Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
156 Posts
Discussion Starter · #1 ·
I'm trying to get DD5.1 passthru from a Turtle Beach Santa Cruz Card. Their technical support suggests putting the card in a non shared PCI port and not to have IRQ Steering.


I've tried using all 5 PCI slots on the ASUS A7V133 with no success. I'm having a difficult time disabling IRQ steering. When I Uncheck "Use IRQ Steering" in the System Properties http://www.avsforum.com/ubb/biggrin.gif evice Manager:System Devices http://www.avsforum.com/ubb/tongue.gif CI bus properties, the OS asks for a reboot. During restart, the operating system recognizes new hardware and installs "IRQ Holder for PCI Steering" at various IRQ locations. Note this is different from the "ACPI IRQ Holder for PCI Steering" prior to Unchecking the above mentioned box.


Any suggestions?



------------------

ASUS A7V133 (Bios 1004, 4in1 4.24.2)

AMD 850 TBird

128 mB PC133

Radeon LE (7075)

Turtle Beach Santa Cruz
 

·
Registered
Joined
·
452 Posts
I wouldn't turn off IRQ Steering. I use that as a diagnostic tool only.


When I was having shutdown problems with my system I told the BIOS "No" for Plug and Play OS and assigned explicit IRQ's to the slots in the BIOS. It also helps to know which PCI slots do not automatically share IRQ's. Go into the hardware properties in your OS and make sure nothing is sharing an IRQ with your sound card.


[This message has been edited by X (edited 05-20-2001).]
 

·
Registered
Joined
·
5,342 Posts
Don't bother, I have had nothing but problems with this card. I spent weeks, even with everything on it's own IRQ, still problems... ATI player stuttering etc. I had much better luck with DD and DTS passthru with the Turtle Beach Montego II Quadzilla.


It only support SPDIF for passthrough, however.


Vern Dias
 

·
Registered
Joined
·
53 Posts
If tech support suggests it, it can't hurt to follow their directions (famous last words). The following is copied from MS's site. Good luck!


To disable PCI bus IRQ Steering, follow these steps:

1. Click Start, point to Settings, click Control Panel, and then double-click System.

2. On the Device Manager tab, click System Devices.

3. Double-click PCI Bus, click to clear the Use IRQ Steering check box on the IRQ Steering tab.

4. Click OK, click OK, and then restart your computer.


------------------

Brian Ness
 

·
Registered
Joined
·
2,912 Posts
IRQ sharing is part of the PCI spec, and there's no reason it should cause any problems.


When a vendor suggests you put their card in a non-shared IRQ slot, it's usually because they don't know what the problem is and they're trying to shift the blame somewhere else. If their card truly does require a non-shared IRQ, it violates the PCI spec and is a piece of junk.


Jeff
 

·
Registered
Joined
·
452 Posts
Quote:
Originally posted by JKohn:
IRQ sharing is part of the PCI spec, and there's no reason it should cause any problems.


When a vendor suggests you put their card in a non-shared IRQ slot, it's usually because they don't know what the problem is and they're trying to shift the blame somewhere else. If their card truly does require a non-shared IRQ, it violates the PCI spec and is a piece of junk.


Jeff
Hmm, then I guess that applies to my Audiophile 2496 which I had to put on its own interrupt under Win98 so my system would shutdown correctly. And also the SB Live that I've heard also has the same problem. These were on Asus CUSL2 boards, so maybe that's the piece of junk. My vote goes to Microsoft though.

 

·
Registered
Joined
·
2,912 Posts
Maybe I oversimplified a bit, but it's an undisputable fact that IRQ sharing is a part of the PCI spec. If you run into situations where IRQ sharing causes problems, it's almost certainly for one of the following reasons:

  1. PCI card is not properly designed to implement IRQ sharing
  2. PCI card's drivers do not properly implement IRQ sharing
  3. PCI controller on your motherboard has problems, either at the hardware level or with the OS's chipset drivers.
  4. OS support for IRQ sharing is buggy[/list=a]


    I think the OS is the least-likely culprit, becuase IRQ problems at that level would prevent pretty much any PCI device from sharing IRQ's. Motherboard chipset problems are a possibility, though it's unlikely with the more stable Intel chipsets. In my experience the most likely culprit buggy device drivers, and while I can't comment on M-Audio drivers since I haven't used their cards, Creative Labs is hardly known for their stellar drivers. Even so, the Live! card in my workstation appears to be sharing an IRQ with other devices. (I say 'appears' because sometimes it's hard to tell with ACPI enabled).


    Jeff
 

·
Registered
Joined
·
13,423 Posts
â€Hmm, then I guess that applies to my Audiophile 2496 which I had to put on its own interrupt under Win98 so my system would shutdown correctly. And also the SB Live that I've heard also has the same problem. These were on Asus CUSL2 boards, so maybe that's the piece of junk. My vote goes to Microsoft though.â€


That sounds odd. I’m using the AP 2496 with an Asus CUSL2 motherboard and have absolutely no shutdown problems. But I am using WinME that has the Windows Fast Shut Down fix applied. Have you applied the MS fast shutdown fix to Win98?



------------------

Best Regards, Cliff

Digital Connection, LLC

[email protected]
 

·
Registered
Joined
·
452 Posts
Quote:
Originally posted by Cliff Watson:
That sounds odd. I’m using the AP 2496 with an Asus CUSL2 motherboard and have absolutely no shutdown problems. But I am using WinME that has the Windows Fast Shut Down fix applied. Have you applied the MS fast shutdown fix to Win98?

That was the first thing I tried. I could find no software "fixes" that worked for the problem as suggested by the MS knowledgebase articles on diagnosing shutdown problems. One diagnostic tool they suggested was disabling IRQ Steering which did fix it. So I took their suggestion about not sharing IRQ's with the offending card which was the Audiophile 2496. I knew that because I rebuilt my system several times with different hardware configs and as soon as I added the 2496 (and latest driver) I got the shutdown problem.


After assigning IRQ's to the slots in the BIOS and making sure the 2496 would not be in a shared-IRQ slot, I totally eliminated the problem. Since I had been looking for help at a CUSL2 user forum I noticed several other people were having the same problem, however it was with their SB Live and maybe a couple other cards. I told them my solution and it worked so well for them I quickly gained minor god status for solving such a widespread problem.


By the way, I didn't have the problem with Win2K.


[This message has been edited by X (edited 05-20-2001).]
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top