AVS Forum banner
1 - 16 of 16 Posts

· Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
I just installed windows 7 on my old desktop and the sound sucks. I've tried 3 different sound cards and could only get one working. The cards that I tried were Turtle Beach - Santa Cruz, Creative - Sound Blaster Live 5.1, and The onboard audio from my Abit KV7. The audio that I did get working from the SB Live sounds real hollow and crappy.


I'm looking for a new inexpensive sound card that has 5.1 digital output to my receiver.


Thanks,


JK
 

· Registered
Joined
·
498 Posts

Quote:
Originally Posted by kartman976 /forum/post/16848257


Just want to make sure the sound card will work with Windows 7. The 3 ancient cards I have aren't supported by win 7.... sound blaster live 5.1 sounds like crap.

what do you mean it sounds like crap. How do you have it hooked into your receiver? analog? does it have a digital output option?
 

· Registered
Joined
·
37 Posts
Discussion Starter · #8 ·
Sound has way to much bass, if you google sound blaster live 5.1 "windows 7", other people are having the same problems as me. The card is too old, and they didn't make official windows 7 drivers...... just wanna get an inexpensive card to replace it. would like to spend less than $50 on one. Would like a coax/optical spdif out.
 

· Registered
Joined
·
498 Posts

Quote:
Originally Posted by kartman976 /forum/post/16848296


I couldn't get the digital out to work.... so I'm using analog at this time.

did you play with your audio settings and select S/Pdif digital sound? The only reason I ask is because I'm also using a 4 year old SB card with optical out and it works just fine.
 

· Registered
Joined
·
37 Posts
Discussion Starter · #14 ·
The problem is definitely a driver issue.


Receiver is Pioneer VSX-1018AH. It's connected analog. The digital connection wouldn't work. I tried several drivers, but they never really installed correctly. I don't think the SB Live 5.1 is supported by windows 7, It's too old. Other people are having similar problems as I am...I wish I could get a digital out. System sounded great on XP with my turtle beach sound card and a digital connection. Thinking about going back to XP on this old machine, or set up a linux media server.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top