AVS Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
1,866 Posts
Discussion Starter #1
Any help here would be appreciated:

I've noticed that my server won't stay asleep for much more than 15-30 minutes even when all computers on the home network are off and nobody remotely is accessing the server. Event viewer has the Realteck PCIe GBE Network Controller as the culprit for waking the server up shortly after entering sleep mode. All day/night the server is being woken up shortly after going to sleep. I've configured updates to occur in the middle of the night and Emby (Mediabrowser) tasks to only run at night as well.

I use Emby (Mediabrowser) and I have lots of devices and clients streaming from the server. Access to the server has never been a problem.

In Device Manager / Network Adapters / Realtek PCIe GBE Family Controller - under the Power Management tab I noticed that "Allow this computer to turn off this device to save power" was checked as well as "Allow this device to wake the computer" was checked. The box "only allow magic packet to wake the computer" was not checked. I experimented by checking the aforementioned "only allow magic packet to wake the computer" box and then put the server to sleep. The result was that the server STAYED asleep as it should with the unfortunate side effect of not waking when attempting to access Emby (Mediabrowser) from any device (laptop, Android phone, etc.). This obviously isn't a viable solution. I unchecked the box and server functionality returned to normal (but again... server won't stay asleep for more than 15-30 minutes at ANY given time).

So my question is: how do I configure the server (maybe via a magic packet) to wake up the server when somebody (either local or remotely) attempts to access Emby? Emby is being used on a ton of different devices (Android phones and tablets, iPad, Roku, Fire TV, HTPC's, etc.)... I have read that using a magic packet app/software of some sort would work, however, I cannot imagine having to teach everyone to do this when they want to stream media from the server. I also read that the router could be configured appropriately to remedy this problem?

I know that some will say just leave the server on or just let it be as there is no real problem (other than the constant cycle of waking/sleeping) but the server sometimes goes 12+ hours between somebody streaming media or accessing data. It would be a complete waist of energy and probably wear on the Hard Drives (as the media grows I buy more Hard Drives... although I am unsure if the Hard Drives actually spin when they aren't being accessed) so I really want this server to just go to sleep when not being used.

What am I missing here?
 

·
Premium Member
Joined
·
1,179 Posts
My guess is that some background application (service) on the server is accessing the network and thus waking the server.

Or some other external device is trying to access the server and thus waking the server up.

Check the Event Viewer - perhaps you can discern what is happening.

Also you may be able to configure the hard drives to spin down when not being accessed. The issue here is that when something needs to access them the time it takes the hard drives to spin up may exceed the time that "something" is prepared to wait and result in an error of some sort.

I have that problem with my NAS unit holding my ripped CDs and my Sonos system. I've just had to educate the family that if Sonos times out the first time try again - the hard drives are up by then.
 

·
Registered
Joined
·
1,866 Posts
Discussion Starter #3
My guess is that some background application (service) on the server is accessing the network and thus waking the server.

Or some other external device is trying to access the server and thus waking the server up.

Check the Event Viewer - perhaps you can discern what is happening.

Also you may be able to configure the hard drives to spin down when not being accessed. The issue here is that when something needs to access them the time it takes the hard drives to spin up may exceed the time that "something" is prepared to wait and result in an error of some sort.

I have that problem with my NAS unit holding my ripped CDs and my Sonos system. I've just had to educate the family that if Sonos times out the first time try again - the hard drives are up by then.
I don't think it is a background process waking the server but I could definitely be wrong.

Checking the box "only allow magic packet to wake the computer" remedied the problem of keeping the computer/server asleep but again it prevented the computer from waking when I tried to stream media from a separate device.
 

·
Premium Member
Joined
·
1,179 Posts
Checking the "magic packet only" option will naturally prevent background processes attempting to access the network from waking the server - since that is the behavior you have selected.

Otherwise any process that attempts to access the network or any external device that attempts to access the server from the network will wake the server.

There are numerous background processes that attempt to access the network, such as applications (including Windows) checking for updates, Windows accessing a NTP server to set the server time, etc.

Also there are lots of things out on the internet that are forever trying to communicate with your server. Your router's firewall may or may not be blocking all of these attempts.

I would like to think that the Windows event log would be logging the things that wake the server but I don't know as I have never looked. I let my server sleep or wake as it wants.

On my NAS units I do spin down the hard drives.
 

·
Registered
Joined
·
1,866 Posts
Discussion Starter #5
Windows accessing a NTP server to set the server time
Ok I wonder what it is that is waking the server up just shortly after being put to sleep. I have noticed that each wake up event has an event that is adjusting the clock with the hardware clock. Could this be what is causing the wake up each time?

How else do I search in Event Log to find out what the culprit is?
 

·
Premium Member
Joined
·
1,179 Posts
I don't know exactly.

You can open the Event Viewer and select the various logs and use the "Find" action to search for things.

For example I searched the System log for "wake" and found this:

The system has resumed from sleep.

Sleep Time: ‎2015‎-‎03‎-‎18T09:41:25.240087500Z
Wake Time: ‎2015‎-‎03‎-‎18T09:41:49.757872700Z

Wake Source: Device -Realtek PCIe GBE Family Controller


But it doesn't say why it happened.

I've never tried to track this sort of thing down.

I'm sure there are folks who know this sort of thing inside and out.

I would be forced into trial and error.

For instance you could open the Date/Time item in the Control Panel and un-check the option to have Windows use the Internet for updating the time and see if that has any effect.

Or you could disable various services (from the Admin menu Service tool) and see if you can find one that has an effect, such as the "Adobe Acrobat Update Service" that is present on my machine.

Other then that you could go to one of the Microsoft Windows forums and ask. They have some pretty sharp folks over there.

Sorry I cannot be of more help.
 
  • Like
Reactions: jhughy2010

·
Registered
Joined
·
1,866 Posts
Discussion Starter #8
I would be forced into trial and error.

For instance you could open the Date/Time item in the Control Panel and un-check the option to have Windows use the Internet for updating the time and see if that has any effect.

Or you could disable various services (from the Admin menu Service tool) and see if you can find one that has an effect, such as the "Adobe Acrobat Update Service" that is present on my machine.

Other then that you could go to one of the Microsoft Windows forums and ask. They have some pretty sharp folks over there.

Sorry I cannot be of more help.
I'm going to try unchecking the box for windows using syncing with the internet time and see what happens. You're right... this is all trial and error.

I have a few other things that research has led me to and I will try: When I get home I am going to see if there is an option in BIOS for "Power on by RTC" and "Power on by Ping" as I have read that these will cause a wake up event.

What would be nice is if Emby had a magic packet feature so that I could check that box: "Only allow magic packet to wake computer" since the only reason I care about it waking up remotely is for Emby and Remote Desktop.

try running 'powercfg /lastwake' from a command prompt to see what is turning the system back on.
It just shows what I have found the culprit to be the whole time: Realteck PCIe GBE Network Controller
 

·
Registered
Joined
·
1,866 Posts
Discussion Starter #10
Do you have WMC installed? If so, it will wake the machine quite often for program guide updates. This can be turned off in Task Scheduler. I do not remember the steps but it should not be hard to find.
Yes I do have WMC installed and it does wake the server/computer to install updates. It usually wakes the computer up around 1 am to do these updates and I see in the Event Viewer that it says WMC being the source of wake.

My problem though is that the Realtek PCIe Network Controller is consistently waking the computer shortly after the computer goes to sleep. On average it stays asleep for 15-30 minutes... although last night I un-installed a ton of programs and went through each piece of software installed and disabled auto-updates... this seemed to keep the computer to sleep for a little longer (the longest stretch was one hour during the night) but this morning I checked Event Viewer and around 5-8 am the computer wouldn't stay asleep for longer than 10 minutes.

So I just checked the box "only allow magic packets to wake the computer" and I'm going to see how long it stays asleep without the Realtek Controller waking it. I just need to figure out how to wake the computer remotely for friends and family who use Emby as I was unable to get my Android Emby app to wake the computer just now... it must not send magic packets.
 

·
Registered
Joined
·
542 Posts
Hmmmm.... Interesting.


I have the same problem with my desktop PC and I gave up trying to fix it. I also have WMC installed. As I check my System log for events, I see the culprit as:

Wake Source: Device -Intel(R) ICH9 Family PCI Express Root Port 5 - 2948
And, like yours, it is happening every 10 to 12 minutes. I'd be curious to see how you resolve this.


EDIT: I also see in the Event viewer that the text in the column header reads: "Power-Troubleshooter"
 

·
Registered
Joined
·
542 Posts
I've done some more research and see that 5 seconds before the "Wake Source" event I mentioned above I am seeing this message:

The system time has changed to ‎2015‎-‎04‎-‎30T17:46:33.500000000Z from ‎2015‎-‎04‎-‎30T17:46:11.561664700Z.
under the heading of "Kernel-General". Some more research led me to this posting on another site: http://www.tomshardware.com/forum/55562-45-changing-frequency-internet-time-synchronisation . But my setting of SpecialPollInterval is 604800 (decimal). And since that setting is supposed to be in seconds, I don't see why I'm getting the time changed message every 10 minutes or so.
 

·
Registered
Joined
·
5,226 Posts
Yes I do have WMC installed and it does wake the server/computer to install updates.
WMC would wake my 8.1 Pro computer quite often so I changed the settings in Task Scheduler and that cured most of the wake-up problems. Some info here. IMO, WMC is crude compared to DVBViewer Pro so I quit trying to use it. Use DVBViewer Pro for satellite recordings and Hauppauge scheduler for ATSC/QAM recordings. Going to test DVBViewer for ATSC/QAM recordings sometime in the near future.
 

·
Registered
Joined
·
1,866 Posts
Discussion Starter #15
Hmmmm.... Interesting.

I have the same problem with my desktop PC and I gave up trying to fix it. I also have WMC installed. As I check my System log for events, I see the culprit as:

Wake Source: Device -Intel(R) ICH9 Family PCI Express Root Port 5 - 2948
And, like yours, it is happening every 10 to 12 minutes. I'd be curious to see how you resolve this.

EDIT: I also see in the Event viewer that the text in the column header reads: "Power-Troubleshooter"
All my wake up events have four entries along with the "power troubleshooter". I'm still not sure what is causing this issue... my gaming desktop doesn't have this same problem, it has a Killer e2200 ethernet controller though and doesn't act as the media server for the home network. Like the server, the gaming desktop has similar entries for wake up events but the culprit usually is something scheduled like windows update etc.

I've done some more research and see that 5 seconds before the "Wake Source" event I mentioned above I am seeing this message:

The system time has changed to ‎2015‎-‎04‎-‎30T17:46:33.500000000Z from ‎2015‎-‎04‎-‎30T17:46:11.561664700Z.
under the heading of "Kernel-General". Some more research led me to this posting on another site: http://www.tomshardware.com/forum/55562-45-changing-frequency-internet-time-synchronisation . But my setting of SpecialPollInterval is 604800 (decimal). And since that setting is supposed to be in seconds, I don't see why I'm getting the time changed message every 10 minutes or so.
I also get the time change message right before the "power-troubleshooter" wake up event. I'm not sure if it is causing the wake up events though.

One thing of note is that I checked the box "only allow magic packets to wake this computer" and the computer stayed asleep today for about 4 hours (I woke it up manually by pressing a key on the keyboard). I experimented some more by putting it back to sleep and turning on my gaming desktop. The result was that the server turned on within about 30 seconds... so magic packet worked perhaps and this behavior is warranted. I put the server pack to sleep and tried Emby (similar to Plex) on my Android phone. It wouldn't wake it. I downloaded a magic pack application and entered in all the data. This app woke the computer up will connected to wifi but when I turned wifi off (simulating remote with 4G) on my phone and tried it didn't wake it up.

The magic packet checkbox might be the solution I am looking for. I just need it to wake up though when my friends and family attempt to access Emby server. I too use Emby server quite a bit remotely.
 

·
Registered
Joined
·
1,866 Posts
Discussion Starter #16
WMC would wake my 8.1 Pro computer quite often so I changed the settings in Task Scheduler and that cured most of the wake-up problems
I'd be interested to know what settings you changed. In my task scheduler WMC seems to be set properly to prevent waking the PC. Also, the wake up events are the network controller. I see the wake up event is different for WMC.
 

·
Registered
Joined
·
542 Posts
I found the specific culprit in my case: A newer option named "Wake on pattern match" on my Realtek PCI GBE Ethernet controller.

I was able to leave the settings on the Power Management tab of the Realtek device properties to my current settings (Allow the computer to turn this device off - checked. Allow this device to wake the computer - checked. And Only allow a magic packet option - unchecked).

But then on the Advanced tab of the same dialog box there's an option named "Wake on pattern match". Set this option to disabled. This is supposed to be a newer and more flexible version of the magic packet wake method. But for some reason, the Realtek was triggering this option every 10 minutes or so. With this option disabled, my PC slept through the night. Yea!

Scott
 

·
Registered
Joined
·
1,866 Posts
Discussion Starter #18
I found the specific culprit in my case: A newer option named "Wake on pattern match" on my Realtek PCI GBE Ethernet controller.

I was able to leave the settings on the Power Management tab of the Realtek device properties to my current settings (Allow the computer to turn this device off - checked. Allow this device to wake the computer - checked. And Only allow a magic packet option - unchecked).

But then on the Advanced tab of the same dialog box there's an option named "Wake on pattern match". Set this option to disabled. This is supposed to be a newer and more flexible version of the magic packet wake method. But for some reason, the Realtek was triggering this option every 10 minutes or so. With this option disabled, my PC slept through the night. Yea!

Scott
That is good to hear. Do you have anything that accesses your server/pc remotely? A few weeks ago I think I experimented with disabling "wake on pattern match" and I wasn't able to wake up my server/PC via Emby on my Android app. I will try it again though.
 
1 - 19 of 19 Posts
Top